iPhone 4S - App Store,iTunes, iBooks, not working via Wi-Fi,only 3G

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kikinecka, Jan 5, 2012.

  1. kikinecka macrumors newbie

    Jan 5, 2012
    My new iPhone 4S (week old) can't connect to iTunes, App Store or iBooks via Wi-Fi (and some other apps e.g. Hollister – but most of the other apps like Safari or ebay work fine). There is no problem with those apps loading via 3G network. When I turn off the wi-fi, it runs over 3G and i can access App store without any problem. When i turn off the 3G network and turn the Wi-Fi on, those apps like App Store won't work, other apps work fine. When i turn on both Wi-Fi and 3G, the App store (and so on) is also not working, other apps are.

    I also found out that when the Wi-fi is on and I sign out my apple ID, the App store starts working! But when I log in again, it will imediatelly stop working. I've tried logging in with others apple IDs, still with the same result. There is no problem with my apple ID account, because it works on my iPad, even via Wi-Fi.

    When i first set up my iPhone, there were no complications using App store ia Wi-fi with exactly the same account. I don't know if it has anything to do with it, but this problem started when i logged in with my UK account and then wanted to log back in with my Czech account.

    I tried turning it off, hard reset and deleting my iPhone several time (even without back up). Nothing worked since then.

    Does anyone have any idea how to fix this? :confused:

    I would really appreciate ANY help. This is driving me crazy! :mad:
  2. dotme macrumors 6502a

    Oct 18, 2011
    I would start by eliminating the WiFi network as the cause. Go hop on someone else's WiFi (Friend, coffee house etc) and see if the problem goes away.
  3. MTShipp macrumors 6502a

    Mar 25, 2009
    Raleigh, North Carolina
    I may have missed it but did you try both the UK and Czech accounts since the initial switch?
  4. kikinecka thread starter macrumors newbie

    Jan 5, 2012
    Yes, I tried both of them. And neither will work via Wi-fi...In both accounts only the "featured" icon will display the app store while logged in, but when i press any app on that page, it won't open anymore. The other icons like "Top 25" or "Search" won't load.

    I also forgot to add,that this problem started after i switched accounts, but also at that time I was synchronising it with iTunes.

    I didn't try connecting to any network other than home yet. I'll do that soon.
  5. Edge21 macrumors newbie

    Mar 8, 2012
    Same problem

    Im from the Philippines and I am experiencing everything you just mentioned. Everything is working on wifi except for app store and itunes. When I turn off the wifi and switch to 3g, app store and itunes seems to be working perfectly. I have tried connecting thru a number of different wifi's and its app store and itunes arent having any problems. Its as if my modem or router has blocked app store's access to the internet in my home, so to speak. This has been frustrating me for days. I live alone and no one could have tweaked settings inside my modem or router. I wouldnt assume that it has something to do with multiple id accounts because my gf and i has been sharing both our accounts for about a month already and this ordeal only started 4 days ago. Sharing meaning sometimes i use hers and sometimes she uses my apple id, together wih card details of course. I tried every reset there is as well and i think it just got worse. Now when I open app store, it diesnt even show the tabs at the bottom (featured, purchased, top, etc.) I'm abit dissappointed with this new gadget as everything is working so perfectly until this. I also have done alot if research and as it turns out, alot of people are experiencing this same incident. If anyone from apple or any genius out there could help us out, we would deeply appreciate it. Thanks.
  6. Qwikk macrumors newbie

    Apr 24, 2012
    I'm in Canada and experiencing the same thing.. I call my ISP to try and figure it out and they said they have no idea.. It's really frustrating.. Still no fix for this?

Share This Page