iPhone 4S - Camera Already Broken

Discussion in 'iPhone' started by Katalysis, Oct 14, 2011.

  1. Katalysis macrumors member

    Joined:
    Jun 13, 2009
    #1
    That was quick. Phone was activated for roughly three hours, and now the camera won't work, and it appears to be a reproducable software issue.

    IF YOU DON'T WANT TO BRICK YOUR IPHONE, DON'T DO THIS:
    1) Open camera app
    2) Turn on grid
    3) Press camera switch button

    BAM - camera locked. Only shows the shutter graphic. If you close it and restart it, you get a black screen. If you close it again, you get a black screen with a grid. Tried resetting a dozen times, and nothing happens.

    I took the phone to AT&T (unfortunately, like an idiot, I ordered from Apple.com) and a simple reset fixed it and the guy looked at me like I was a moron. Then, I say, well, hit those buttons, and BAM, locked again. Resets have not undone it. I am going to try an itunes restore right now.

    Anyone else having camera issues?
     
  2. MrWaffles macrumors member

    Joined:
    Mar 4, 2011
    Location:
    Asheville
    #2
    I just posted in the other thread about my flash not being timed right. It seems to go too early so it doesn't affect the shot at all.
     
  3. FetalSage macrumors regular

    Joined:
    Jul 5, 2007
    #3
    Doesn't break for me. Might be a hardware issue?
     
  4. Katalysis thread starter macrumors member

    Joined:
    Jun 13, 2009
    #4
    We shall see. I am restoring the phone right now. The only Apple store is 4 hours away, so I guess I am screwed. Hopefully they can reactivate my 3GS.

    ----------

    Edit: It has to be software. I restored it, set up as a new iPhone, hit the grid, hit the camera reverse, and it locked again.

    Maybe my front camera is broken?
     
  5. greytmom macrumors 68040

    greytmom

    Joined:
    Jun 23, 2010
    #5
    I followed those steps as well and it didn't happen for me either. I hope your restore will clear things up.

    ----------

    Easy way to check - if you can get it to unlock again, switch to front camera without turning on the grid. If it happens again, I would say it's a front camera issue.
     
  6. Katalysis thread starter macrumors member

    Joined:
    Jun 13, 2009
    #6
    Restored, tried the front camera, and it locked. It's just a front camera issue, because a restore will allow the rear camera to function.

    Great. :mad: Now I either have an 8 hour round trip drive or deal with shipping my phone back. I am guessing there is literally no chance of them sending me a brand new one and then I send back the bad one?
     
  7. outz macrumors 6502

    Joined:
    Jul 17, 2007
    #7
    they will most likely do that if you give them a cc to bill if you don't return the broken one. i doubt they would want a customer to be without a working phone. call and ask...
     
  8. lnferno macrumors 6502

    Joined:
    Jun 19, 2008
    #8
    I had this exact same issue (only the front camera, rear facing worked fine). It was stuck with that black shutter screen. I left it like that for about 15-20 minutes (had to do some other things in the house), rebooted the device (held the lock and home screen for 10 seconds) and it magically cleared up the issue.
     
  9. Katalysis thread starter macrumors member

    Joined:
    Jun 13, 2009
    #9
    I sent up a call with a customer support for later this week. I also went to post on the Apple forums and there are a ton of people with the same or similar problem. Could this be a software issue? I really doubt there could be that many camera modules gone bad.

    https://discussions.apple.com/message/16377123#16377123

    https://discussions.apple.com/thread/3389693?tstart=0
     
  10. everlong44 macrumors newbie

    Joined:
    Oct 14, 2011
    #10
    Same here

    I just starting have this problem. When you press the camera flip button, it locks up the camera app for good and will only show either a shutter picture or a black screen. A restore fixes it, but if your press the flip button, it happens all over again... Anyone find a fix yet???
     
  11. MarcBook macrumors 6502a

    MarcBook

    Joined:
    Jul 13, 2008
    Location:
    Jersey, Channel Islands
    #11
    This is very strange. I just tried what you described several times with my 4S and it works perfectly. In fact, I never noticed how quickly it switches cameras until now!

    If it keeps happening, I reckon it's a hardware issue and you should take it in.
     

Share This Page