iPhone 4S failing to sync photos via iTunes and iPhoto

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sams89, Oct 16, 2011.

  1. sams89, Oct 16, 2011
    Last edited: Nov 29, 2011

    sams89 macrumors newbie

    Oct 16, 2011
    Manchester, UK
    First, a timeline of events:
    Using iPhone 3GS, updated iTunes and iPhoto to most recent version (and I have double checked that they are), synced 3GS twice before my new 4S was delivered on the 14th. New sim card, 4S activated, 3GS deactivated, returned 3GS to factory settings.

    I then set the 4S up and all seemed well. Then I plugged it back into iTunes and commenced syncing my music onto it. Despite numerous attempts, each time I set it up and left it, I would return to find iTunes saying it had finished the sync, but no music actually having been copied. The 4S would appear to still be syncing though, with the little spinning "sync" icon showing. This continued to spin when iTunes was closed, the phone was unplugged and no wifi was involved. In order to stop the "sync" I had to restart my iPhone. The music I was attempting to sync was exactly the same as that which had been on my 3GS hours before.

    After each attempt I returned the 4S to factory settings.

    On the next occasion I remained in the room while it synced. My (new) iMac began the sync and then turned off the screen to save energy. I double checked (wiggled the mouse) to confirm it was still syncing. It was. The second time the screen turned off I ignored it. Then the iMac HDD span down. I assumed it was finished. It hadn't. iTunes was hanging. When I attempted to re-sync, iTunes told me that the 4S had 32GB of "other" on it (which I know refers often to data left behind by failed syncs).

    Returned to factory settings again.

    This next time I watched the whole sync, wiggling the mouse every 2 minutes. Finally, the music managed to copy. I observed that iTunes had inserted several steps into the sync process. It had been:

    "Backing up" > "Syncing email" > "Determining tracks" > "Copying tracks" > "Copying photos"

    This had changed to:

    "waiting to sync" > "Backing up" > "Syncing email" > "Determining tracks" > "Copying tracks" > "Copying photos" > "waiting to copy data" > "Copying Genius data" > "waiting to copy data" > "Copying photos" > "Finishing sync"

    (I notice someone else has queried what the "Genius data" step involves)

    I then tried to sync the photos. The first time I set them all to go in one big lump. This screwed the phone up again and I had to restore it to factory settings all over again. Tried again, synced music and then synced photos in batches of about 1500 (I have a lot of photos).

    Photos were copied successfully about 20% of the time. Each time data was successfully copied the "waiting to sync", "waiting to copy data" and "finishing syncs" hung for about 3 to 5 minutes *each* (measured with a stopwatch).

    The other 80% hung at one of these steps for times in excess of 7 minutes, at which point I gave up and attempted to cancel the sync. When I did, the "cancelling sync" hung for about 7 minutes. I then gave up and was forced to unplug the phone and restart it.

    At this point in time, I have managed to copy the larger part of my photo library across however, now it refuses to copy *any* data at all. I tried to delete all the photos off to start again without restoring to factory settings but the sync just hangs at the "waiting to sync" stage.

    I have tried forcing it to start syncing again by changing the data to be synced, but this doesn't achieve anything other than causing it to start hanging all over again.

    The photos, just like the music, is exactly the same as that which had been on my 3GS, only now I have a larger capacity phone. (64GB from 32GB).

    So, questions:

    Why are all these new steps added to syncing and what do they do?

    Why do these steps take so long?

    Why, when these steps take so long, does my iMac believe the HDD is not being accessed and spins them down?

    More importantly, why, when any photos are introduced, does the 4S freak out?

    Is this a software issue (iOS5) or is this hardware?

    Does anyone else have this or a similar issue? It might be an issue with this particular piece of hardware, in which case, I'll need to get a replacement 4S

    Note: Despite it being an issue with music and photos, I'm going to restore the thing to factory settings (again!), rebuild my iPhoto library, remove the old iPhone folders from the iPhoto package and start again. I will update if this solves anything.
  2. cbronfman macrumors 6502

    Feb 24, 2008
    Washington DC
    Misery appreciates company

    I've had the same problem. With my first iP4S, nothing synced except contacts, calendars, etc.in the cloud. And mail worked great - phone is speedy. Safari is fast etc. I started reinstalling apps from purchases. I then was on the phone for hours with Apple Care, the first tech had me do everything you say - no avail. The second tech reviewed everything and said the phone must be defective. So I made an appointment at the Genius Bar and got a replacement.

    Took it home - this time - apps sync fine - although spread out all over the phone so I spent hours yesterday organizing them. AND music synced. BUT not my audiobooks (a playlist right with the music ones in iTunes) and not my photos or one of my movies.

    I've tried everything - reset sync from terminal, repaired disk permissions etc., resynced my 3GS to see if the problem was repeated (NOT). I even created a photo folder on my desktop to see if the problem was with iPhone.

    Another tech from Apple Care was going to research the issue and call me back this PM. Pessimistically, I made an appointment for Monday early PM at the Genius Bar. The iP4S is using roughly the same allocation of storage as the 3GS (3.5 to Video where only 1.9 is visible), 4.7 to Audio (2 are identical but where the books are there on the 3GS, they aren't visible on the iP4S although grayed out in sync. No photos.

    And yes, iTunes hangs when I try to sync. It's as if it and the iP4S stop communicating - the iP4S sync wheel stops spinning, iTunes keeps trying and hangs.

    I'm very frustrated but slightly less miserable knowing I'm not totally the only one.
  3. sams89, Oct 16, 2011
    Last edited: Oct 16, 2011

    sams89 thread starter macrumors newbie

    Oct 16, 2011
    Manchester, UK

    I don't have a problem with the actual running of the phone either. And my apps sync fine (although, like you say, they're spread over five home screens).

    Update: Rebuilt my iPhoto library and deleted all the iPhoto iPod back-ups. Have tried syncing all in one go (which failed, obviously, but interestingly reported that 7.5GBs of photos would take up about 24GBs when I copied them onto my 4S...) Restored to factory settings again

    And started again, this time without using the 4S *at all* until I had copied all my music and photos onto it. I haven't synced any apps or email data yet. Haven't even powered it up.

    Copying music now seems A-okay, but requires mouse wiggling. For two syncs after the music was copied, iTunes was *still* copying album artwork across. Goodness knows why it didn't do that originally.

    Observations: I have 286 lumps of Genius which apparently need copying every time I sync.

    The copying bar in iTunes appears to function on an exponential scale. 50% through a copying process involves filling about 10% of the bar. 90% through a process involves filling 50% of the bar, etc.

    Importantly: I don't think the 4S has stopped responding. I've just noticed (I'm currently copying the photos through, 1 event at a time) that the amount of time spent "waiting for items to copy" is directly proportional to the amount of data already on the phone.

    This means, with nothing already on, you don't need to wait. With 1GB already copied on, you need to wait about 4 minutes. With 5GB on, you need to wait 20 minutes. What can be mistaken for hanging is just an incredibly long waiting process. When you're copying large bundles of data in one go, iTunes simply gives up, but not when you split it up into smaller batches.

    I think, although I can't prove it, that the 4S is *telling iTunes* everything it already has copied onto it. Exactly what it has on it, on a byte by byte level, then comparing it against what needs to be copied. When you have about 30GB already on it this takes rather a long time.

    I haven't finished copying the photos yet. I may never be able to do it. I can only imagine what it will be like when I have my existing library copied onto the phone and I take a single photo with my SLR and want to put it onto the 4S... What used to take seconds may take days...

    Have got a Genius Bar appointment for tomorrow morning.

    EDIT: It took about 6 and a half hours, but I have managed to copy all my data onto my 4S. The trick it seemed was to have faith in the sync and just find something else to do (as long as it doesn't involve using your computer or phone). Example: The final two photographs (alone, not including other data synced at the same time) took 35 minutes to copy (again, I used a stopwatch). I just hope the Genius Bar can tell me how to do it in a 600th of that time...
  4. cbronfman macrumors 6502

    Feb 24, 2008
    Washington DC
    Genius Bar this afternoon

    Tech I spoke with last night suggested I bring my mini and my iPhone so off I go this PM. Something is wrong. I'm keeping your saga handy in case I learn something different and will post.
  5. sams89 thread starter macrumors newbie

    Oct 16, 2011
    Manchester, UK
    After further investigation...

    Tech suggested I did the same, but I'm going to fiddle for a little longer before I try and take the iMac in (which will be a faff).

    Have you tried moving images from you photo stream into a new album on your phone?

    [Photo Stream] - [Arrow out of box] (top right) - [Photo] - [Add to] - [Add to New Album]

    It also works with normal events too I believe.

    When I do it the Photos App freezes. I escape it with the home button and then when I re-open it, the app crashes. When I restart the app it works completely fine and the photo has been copied perfectly. Maybe there's a bug in the Photos App? Or perhaps the way in which certain 4S-es handle (specifically, *move*) photo data which manifests itself in both photo syncs and "Add to new album"s?
  6. sams89 thread starter macrumors newbie

    Oct 16, 2011
    Manchester, UK
    Update (a long time later)

    Just so anyone passing knows, I have identified (but am unable to fix) the problem. AFAICMO the 4S (or perhaps iOS5), differing to the 3S (or iOS4), when syncing photos does not just copy the photos which need to be added to your phone. Instead, in addition, it re-copies every photo already on your phone.

    Because iTunes is designed to only show copying of data "it is supposed to be copying", when copying data already on the phone it states that it is "waiting for items to copy" and shows a candybar.

    Reason: unknown. I'm guessing it's some sort of design flaw. With small to average size photo libraries, the effects of this are invisible, the time taken to copy across anything up to 2000 photos is negligible. When copying large libraries, however (mine is 10.3GB) this waiting period is unbearable. It's also very easy to assume iTunes is hanging because it isn't giving any feedback.

    The only solution I've found is to have plenty of time on your hands. Syncs may take up to an hour over USB 2.0 before they actually "start copying", you just have to hang in there and put your trust in iTunes.

    The upshot is, however, that, whether you have changed your photo library or not, every time you sync your 4S you will be forced to wait for an hour. This means that, even if you intend to sync a single song, ringtone, film, app or book you will be required to wait "for items to copy" (read: "for your whole photo library to be redundantly copied").

    Furthermore, unplugging your iPhone while "waiting for items to copy" will deposit a whole lump of "other" on your phone, that is, your whole photo library, essentially (in my case) becoming 10.3GB of unreadable data which cannot be removed except with a restore to factory settings.

    I'm going to try and report this.
  7. sams89 thread starter macrumors newbie

    Oct 16, 2011
    Manchester, UK
    One final update

    The reason I am certain of this issue is how predictable the waiting periods are. Essentially, take the amount of time your last sync was in total and this will equal (give or take a 60 seconds) the amount of time you will need to wait.

    Just finished a sync which I calculated would be 54 minutes. Actual time: 54 minutes. Hey ho.
  8. mic.o macrumors newbie

    Dec 12, 2011
    This worked for me

    1. Close iPhoto
    2. Unplug iPhone
    3. Go to Utilities Folder
    4. Open Activity Monitor
    5. Find PTPCamera in the list of processes
    6. single-click on PTPCamera to highlight it
    7. Click on Quit Process
    8. When pop-up window appears, confirm "Quit Process" (no need to Force Quit)
    9. Open folder: Mac HD>System>Library>Image Capture>Devices
    10. Double-click on PTPCamera (to restart process)
    11. Plug-in iPhone

Share This Page