iPhone 4S "No Service"

Discussion in 'iPhone' started by AkuskaUK, Oct 17, 2011.

  1. AkuskaUK macrumors 6502

    AkuskaUK

    Joined:
    Mar 18, 2011
    Location:
    Shanklin, Isle Of Wight
    #1
    I received my iPhone 4S (64GB White) today, since turning it on and putting my iPhone 4 simcard in there it is coming up with "No Service" after searching, if i put the sim back into my iPhone 4 i get full bars. I am on 02-UK, can anyone help me? it said that the iPhone activated when i set it up, why is it messing me about now?
     
  2. derekm323f macrumors newbie

    Joined:
    Jun 22, 2010
    #2
    Hey,
    I also was having this issue and so was my brother. After waiting a few hours i figured it was not still activating so i did this:

    1. Go to settings then Carrier

    2. Change the search method from Automatic to Manual and wait for Service Provider list to pop up

    3. Select your Operator

    4. Service then begins and I just switched it back to Auto

    Hope this helps

    Derek
     
  3. thunderbunny macrumors 6502a

    thunderbunny

    Joined:
    Jul 15, 2010
    Location:
    Cheshire, UK
    #3
    My 4S had to be swapped out yesterday because of reception problems, not as bad as you describe though. If yours persist book appointment at your nearest Apple Store.
     
  4. ApplesAndOrangs macrumors regular

    Joined:
    Sep 30, 2011
    #4
    Mine was randomly out of service for a couple of hours.

    Turned it off, and on, then got service.

    ----------

    Don't see Carrier in settings
     
  5. derekm323f macrumors newbie

    Joined:
    Jun 22, 2010
    #5
    After a few seconds the Carrier field popped up under Location Services. Afetr I removed my sim it disappeared.

    So I guess it was reading my sim even though it was displaying no service.
     
  6. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK
    #6
    No wonder it's not working. O2 sucks, and not in the good way.

    It's most likely just plain broken. Take it to your nearest Apple store, they'll swap it out. Don't take it to O2, you'll lose it for a month while they fart about sending it off for repair.
     
  7. nexsta macrumors 6502

    Joined:
    Jul 21, 2007
    #7
    Many iPhones with german sim cards have this problem too, try to disable the sim pin, then it should work normaly.
     
  8. HassaanAbdeen macrumors newbie

    Joined:
    Aug 4, 2008
    Location:
    Jordan & KSA
    #8
    It seems I'm not alone with this problem!

    I noticed my 4S takes longer to find the network than my iPhone 4. But that's no big deal. The problem is that
    1) all of a sudden it loses the signal and says No Service.
    2) i shift choosing the Carrier from Automatic to Manual.
    3) I get to see my carrier name and choose it manually but still doesn't work.
    4) The only way to solve it is to turn the iPhone off then back on.
    5) This happened twice so far in the first 12 hours since I got my iPhone.

    Should I be alarmed?
     
  9. Reach macrumors 6502a

    Joined:
    Sep 7, 2006
    Location:
    Norway
    #9
    Same thing here. It does not happen often, but it has happened 3-4 times now.
     
  10. daleski75 macrumors 65816

    daleski75

    Joined:
    Dec 10, 2008
    Location:
    Northampton, UK
    #10
    Just got my iPhone 4s on Orange and seeing the same symptoms it will flick to no service and back again randomly.

    Also mine flips between 2g and 3g when there is a good 3g signal and the phone is just left on my sofa!

    Roll on 5.0.2....
     
  11. Gearoidol macrumors newbie

    Joined:
    Mar 24, 2011
    #11
    Suffered same problem here in ireland.
    Its 1 of 2 things

    1) there is a bug when sim pin is enabled that causes no service

    2) like mine the handset is faulty.I had it for over a week and it was constantly out of service or else it had fullservice but if you tried to make a call if would say call failed.I recieved a swap out from apple yesteday and the new 4s is perfect.
     
  12. macjunk(ie) macrumors 6502a

    Joined:
    Aug 12, 2009
    #12
    have the same problem here in Singapore as well...Happens during a call cause of which the call fails. The phone takes a few seconds to get the network from then on. I am hesitant to take it back...apart from this, I have no problem with the phone so far.
     
  13. Ballis macrumors 6502a

    Joined:
    May 27, 2008
    Location:
    Oslo, Norway
    #13
    Apparently, this is a microsim issue. According to Telenor (Norways biggest carrier, the 4S requires a microsim created after march 2011 in order to work properly (don't really know if that timeframe applies worldwide, or just to their sim cards) They say to temporarily fix the problem while waiting for a sim replacement, turn the sim passcode lock off.
     
  14. MiniMoke macrumors member

    Joined:
    Nov 12, 2009
    #14
    Hi, My 4s worked allright before updating to 5.0.1..... well apart from the horrendous battery drain syndrom.

    After updating only, it's loosing the carrier signal constantly. My provider here in Luxembourg tells me it's a 'known problem with the update' (well, yesterday they said it was a problem with their network).

    Wife's iPhone 4 works allright!

    Anyone got an idea?

    Edited to add: I got a new sim card from the provider to try if it was faulty, I reset the phone and did a complete restore......
     
  15. KusanagiK macrumors newbie

    Joined:
    Nov 12, 2011
    #15
    Hello,

    As MiniMoke, since I did the upgrade to 5.0.1 on my Iphone 4s, I've been experiencing network issues.
    First I thought it was a providers issue - i'm on LuxGSM - Luxembourg, but now that I'm seeing that a lot of people are having the same issue, i'm really convinced that the upgrade wasn't all that beneficial.

    I've also seen that it happens a lot more if I have wifi on or 3g activated...not sure what to make of all of this.

    I sure hope that Apple finds a solution quickly to this...
     
  16. MiniMoke macrumors member

    Joined:
    Nov 12, 2009
    #16
    Moien KusanagiK,

    Same carrier here... LuxGSM!

    Hope this gets sorted out soon - I need that phone!!!!
     
  17. Mr.C macrumors 601

    Joined:
    Apr 3, 2011
    Location:
    London, UK.
    #17
    I'm using the same micro sim I got with my iPhone 4 at launch last year and it seems to be working fine.
     
  18. HassaanAbdeen macrumors newbie

    Joined:
    Aug 4, 2008
    Location:
    Jordan & KSA
    #18
    I managed to solve the issue by disabling choosing the carrier automatically. If you choose it manually, this problem gets solved.

    Good luck
     
  19. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #19
    Wirelessly posted (iPhone 4S: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    I've noticed the same thing in the last day. I'm on AT&T and the tower is less than 1 mile from me and traditionally I always have a full strength signal.

    I've noticed it said no service last night and thought AT&T was working on the tower over night, but I've seen it go to Edge a few times or get poor signal for a minute and then back to good 3G signal.
     
  20. HassaanAbdeen macrumors newbie

    Joined:
    Aug 4, 2008
    Location:
    Jordan & KSA
    #20
    One more thing I forgot to highlight. It's important to turn the sim card pin off. Otherwise every time it starts searching for the network it will fail to reconnect
     
  21. mush03 macrumors newbie

    Joined:
    Oct 2, 2010
    #21
    i think theres somethin wrong with my iphone 4s. whenever i pick it up it always drops 1-2 bars or even lose signal completely

    just did a test and lost service on the iphone... my nexus one right next to it still has 2 out of 4 bars:(
     
  22. Sir Ruben macrumors 65816

    Sir Ruben

    Joined:
    Jul 3, 2010
    #22
    Okay from reading through this thread you are not all experiencing the same thing. There are two distinct issues:

    1) Losing signal which comes back again by itself.

    2) Losing signal WHICH WONT COME BACK UNTIL YOU REBOOT THE PHONE

    The second issue I had on a family members iPhone, I asked on these forums for help but didnt get one single reply. Oddly enough a search of the interwebz found that a lot of people get this problem, so maybe people on here arent as clued up as they claim to be ;)

    So I set out to fix it myself, and I did. I came to the conculsion that somehow the software/firmware that runs the phones cellular modem had become corrupt. Either that or the antenna had become faulty. Resetting network setting etc does not resolve. Neither does tweaking the carrier settings. Here is the only way I was able to resolve it:

    1) Downloaded a fresh copy of IOS 5.0.1 to my PC.
    2) Connected the iPhone to iTunes
    3) Put the phone into DFU mode which prompts iTunes to tell you it needs to be restored
    3) shift key and restore button in iTunes prompts you to specify the file location
    4) Browsed to my freshly downloaded IOS file
    5) Phone restored perfectly and is now fixed

    If that hadnt worked there is literally nothing else to try and it would have gone back to Apple for repair. I also dont believe restoring the phone in the usual way (through iTunes or on the phone itself) would resolve the problem.

    By putting the phone into DFU more you are absolutely restoring everything. Any other method does not restore the phone in the same way.

    Good luck and let me know if it works to you too!
     
  23. MuGeN PoWeR macrumors 68000

    MuGeN PoWeR

    Joined:
    Jun 29, 2011
    #23
    i was facing the same problem!! got a new micro sim from my carrier and evertthing is fixed now!! working fine now!
     
  24. THE VOICE macrumors newbie

    Joined:
    Nov 14, 2011
    #24
    Update 5.0.1 same ****

    This is really a big pain. If its not fixed in a couple of days then I will request a refund Its not iphone for steve (4s) its iphone for scrap
     
  25. daleski75 macrumors 65816

    daleski75

    Joined:
    Dec 10, 2008
    Location:
    Northampton, UK
    #25
    Mine seems to be settling down now and not seen no service for a few days or it could just be I haven't noticed!

    If it happens again might try the DFU trick.
     

Share This Page