iPhone 4s not receiving texts, dropping signal

Discussion in 'iPhone' started by BJB Productions, Jul 12, 2012.

  1. BJB Productions macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #1
    Alright I thought I'd just try here before calling up ATT or Apple support. Apple will just say reset the phone and ATT will probably have no answers.

    Short and sweet: My phone does not receive most text messages unless I ask a certain friend to text me at which point his text gets delivered along with a flood of other texts that are hours old. It seems to happen after I've been out of cell range (i.e underground at my office) and then when I reconnect to the network, (while it eventually reconnects), it does not send me my pending texts until it's forced to.

    Also, randomly even with full bars my phone will lose signal and signal is very weak.

    Thoughts? I'm thinking it's a phone issue and not ATT.
     
  2. Zaft macrumors 68040

    Zaft

    Joined:
    Jun 16, 2009
    Location:
    NYC
    #2
    is your phone jailbroken?
     
  3. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #3
    No, it is not. It's also updated to the latest iOS.
     
  4. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #4
    You didn't mention if this is a new phone or just a new problem. Is your cellular data turned on in settings? If so then try to reset your network settings yet?
    (Settings->General->Reset->Reset Network Settings)

    Also, do you still have this problem when connected to wifi?
     
  5. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #5
    This is an old phone, new problem. I just did a network reset. We'll see if it works.

    ----------

    Okay, i did the reset and it seems to be working now actually. However, wifi is not connect and it was before. I wonder if it's possibly related to wifi.
     
  6. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #6
    Do you have it set for your wifi to attempt to connect automatically? If so, it should ask you to log into it. If not, you have to add it manually.
     
  7. BJB Productions thread starter macrumors 65816

    BJB Productions

    Joined:
    Nov 10, 2008
    #7
    Right now I have it to ask me to join networks first. I've kept wifi off for most of the day and it's being doing alright, though the signal has been spotty. Just now though it also shut itself down, then revived itself for no reason at all.
     
  8. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #8
    I've had mine do that in the past too. Kinda weird. But it doesn't do it much, so I don't pay it attention. Heck, MS Windows does that on a regular basis and they say its one of the features. :D
     
  9. madridista59 macrumors regular

    Joined:
    May 19, 2010
    Location:
    Houston, TX
    #9
    i had issues with my txts not sending for a few days and called up at&t got past the first customer service rep and to a tech who basically had me turn off the phone while they reset the towers i was communicating with or something along those lines and everything is peachy now.
     
  10. MuGeN PoWeR macrumors 68010

    MuGeN PoWeR

    Joined:
    Jun 29, 2011
    #10
    i had the same problem with the iPhone i bought on the launch day. the Signals were dropping randomly. if someone called me it said cell is switched off where as i had full signal bars. i was unable to send the text messages. but the data plan used to work fine. i tried resetting network settings. restoring bla bla everything. in the end i sent it back to apple and they gave me a new one. and then no problem what so ever.
     

Share This Page