Iphone 4S Reception problems

Discussion in 'iPhone' started by shortydk1, Nov 6, 2011.

  1. shortydk1 macrumors newbie

    Joined:
    Nov 6, 2011
    #1
    Hey guys.

    I just got me a iphone 4S, and when i use it it works perfect. But sometimes when i move from one place to another, i cant send sms and make/recieve Calls. Then i have to shut down my phone and turn it on again and then it works again.

    I work at this tele company doing netowork stuff and looking for errors in the 2G and 3G. To me when i look at the iphone, it says Carrier name plus 3G and 5 bars. but the phone dosent work.

    Then shut down and turn on again and it works again.
    Sometimes i see that when i try and call out, then it says "No service". and suddentlyg it gets reception.

    It is not the phone. I have a few customers that calls in with the same problem

    We have like 10 cases of this in the company where i work.

    Anybody tried this?
    Or somebody knows what happens

    To me it looks like the two antennas in the phone, looses connectivity when i travel from one location to another
    Maby handover problem of some sort.
     
  2. reclusive46 macrumors 65816

    reclusive46

    Joined:
    Apr 14, 2011
    Location:
    Canada
    #2
    I'd try a restore and if that doesn't work try getting it swapped out. Just because there are 10 other cases doesn't mean its not a handset problem. They could all have it.
     
  3. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #3
    That's not a lot of info to go with. Which carrier is your 4S on? How do other phones on the same carrier fare in the same conditions? If you put your iPhone in Field Test Mode, what numeric signal reading does it give you?


    I just gotta say, this is the most non-technical, uninformed post I've ever seen about reception and how the antennas work, and from someone who I would think would know better given the job they say they have.

    You say at one point it's not the phone. Then you turn right around and produce a theory about the antennas losing signal. So which is it? If it's the network, then we're least able to help you. The company you work for seems to be the one who should have the answers here.

    If the carrier you work for has that much trouble with network and reception, and this is indicative of how they find answers to their network problems, then I'm not surprised.
     
  4. shortydk1 thread starter macrumors newbie

    Joined:
    Nov 6, 2011
    #4
    i work at Telenor Denmark.

    Well the thing is, i cant tell how the phone works, all i know is that its not network, cuz when 2 out of 10 on same location have the problem, then i guess its some sort of handset problem.

    All i wantede to know was if´other people have the same problem.

    Funny thing is when i do make a outgoing call, nothing happens, then 20 seconds after it starts looking for network.
    Again im not that technical, just need to know if other ppl have the same problem.
     
  5. OW22 macrumors 6502

    OW22

    Joined:
    Sep 3, 2006
    Location:
    Dublin, Ireland
    #5
    There a lot of issues being reported with this. I am in Ireland on the Meteor network and got the phone on Friday. Same issue. Phone shows 4 bars say and will be working fine but then I'll go to send another SMS or make a call and nothing...Despite the bars still showing good coverage and the 3G being displayed. It will then drop the coverage, show no service, before beginning the search and hooking up to the network again and everything will seem fine but it comes back again. I've tried this in multiple locations in the city, all similar results.

    Some folks have suggested turning off the Sim PIN in the iPhone. It helped the situation for some but not others. I have tried resetting the network settings, general settings etc.

    One poster on the Apple Support Communities posted his diagnostic log and showed the modem crashing, he said the baseband was re-setting all the time.

    Lot of folks in Denmark and Sweden seem to be having issues. Other countries now reporting in as well.

    Other chap posted this from diagnostics "modem reset. Call state out of sync"

    https://discussions.apple.com/thread/3396554?start=0&tstart=0
     
  6. varunkrish macrumors member

    Joined:
    Jun 7, 2009
    #6
    Hi Guys ,

    I picked up a white iphone 4S 16GB and a black iphone 4S 32 GB from the covent garden apple store in UK. The models i bought are factory unlocked and i paid for the full price for it as on Pay As You Go.

    Both the phones where working fine on O2UK and 3UK when I was in London.

    Now I returned to my country , India and the Black 4S just refuses to get any signal bar. Strangely data works on it.But calls and messages never go through.

    Surprisingly the White iPhone 4S works completely fine with the same SIM card, calls , messages , data all work fine on it.

    Im wondering if its a hardware or software issue coz if i have to send the phone back to apple uk , its gonna be a bit difficult. Anyone else facing a similar issue with the iPhone 4S ?

    I have tried resetting , restoring .. heck i have even tried the new 5.01 beta as i m a developer..no luck..

    See the pic below to see what i mean
    [​IMG]
     
  7. mustu macrumors 6502

    Joined:
    Nov 5, 2011
    #7
    Hi Varun,

    Well check if the model number of the non working phone is 261B/A

    If so there is a bi time issue with this. I got a 64GB on launch day from the Uk store and have no issues in Bombay with this. But I know know that most UK phone purchased from the apple store land up with no signal bars. I know as a friend wanted one and is facing a issue.

    Try and MTNL sim it will work for sure.
     

Share This Page