iPhone 4S WiFi disconnectivity issues

Discussion in 'iPhone' started by bluedoggiant, Sep 23, 2012.

  1. bluedoggiant macrumors 68030

    bluedoggiant

    Joined:
    Jul 13, 2007
    Location:
    MD & ATL,GA
    #1
    Probably a bad time to post because of all the iPhone 5 hype, but I've noticed my iPhone 4S always disconnects from my home WiFi network. Ill be using it, then every 20 minutes or so it will fall back on cellular, then reconnect a minute later. If I go to settings to see whats up, my home network doesnt even show up even though all my other devices are connected just fine. It is a persistent problem that is gradually getting worse, over the past few months. I don't have this issue with an other device in my home, anyone else experience something like this?
     
  2. AAPLinc macrumors 65816

    Joined:
    Jul 27, 2012
    Location:
    Hollywood, CA
    #2
    My 4S does this from time to time. It doesn't bother me that much, because it doesn't happen often... but I might take it to an Apple store this week and get it replaced... I mine as well since my Warranty is up at the end of November.
     
  3. megsalias macrumors regular

    Joined:
    Jun 23, 2010
    Location:
    Mobile, AL
    #3
    Do you have the "ask to join networks" switch on or off? I had that issue, and had that switch set to "off". I flipped it and haven't had an issue since. It's possible that it's a coincidence, but I thought it's worth mentioning.
     
  4. bluedoggiant thread starter macrumors 68030

    bluedoggiant

    Joined:
    Jul 13, 2007
    Location:
    MD & ATL,GA
    #4
    It's on. I am thinking it could be a hardware issue because its been getting progressively worse, quite irritating because when it falls back to cellular (AT&T's "4G"), its as if the phone realizes its supposed to be on WiFi and i actually dont get any connection from cellular, so its not like I can still use it in that minute or two it takes to reconnect to WiFi.
     

Share This Page