iPhone 4s + YouTube App = lag

Discussion in 'iPhone' started by YsoSerious, Jan 31, 2012.

  1. YsoSerious macrumors 6502

    YsoSerious

    Joined:
    Oct 8, 2008
    #1
    I had this problem with my iPhone 4 with YouTube video playback lagged all the time. Now having upgraded to the 4s,it seems like the problem hasn't been fixed. It's not my wifi cause, I get and pay for fast Internet connection. I've tried all the remedies like clear safari cache, close other apps, and even switch to 3G--which by the way works better then Wifi.
     
  2. Frenchjay macrumors 68000

    Frenchjay

    Joined:
    Jul 6, 2010
    #2
    Visit the Mobile YouTube site and save it to your Homescreen. It's way faster than the stock browser.


    http://www.youtube.com/mobile
     
  3. sparky1499 macrumors regular

    sparky1499

    Joined:
    Oct 5, 2008
    Location:
    Glasgow, UK
  4. Slicktype macrumors 6502

    Slicktype

    Joined:
    Nov 8, 2011
    #4
    Not sure why that's happening because mine works flawlessly. No lag at all.
    I too would be upset because I watch YouTube videos on a daily basis.

    Side note: Stop SOPA !
     
  5. shadrap macrumors 6502

    Joined:
    Jul 6, 2009
    Location:
    Mayberry
    #5
    Same here, no issues.
     
  6. mattraehl macrumors 6502

    Joined:
    Feb 26, 2005
    #6
    Ugh, YouTube is slow no matter how or when I use it. On my computer, the iPhone, morning, night you name it. I have a 20 Mbps connection, all other sites work fine and load quickly. YouTube always loads the first 25% of a video quickly then just slows to a crawl. Crappy site.
     
  7. Xcallibur macrumors 6502a

    Xcallibur

    Joined:
    Jul 24, 2011
    Location:
    Manchester
    #7
    You will find on the YouTube app, only the following 10% of the video is loaded, the mobile version of YouTube is much better as it tends to buffer much more than the following 10% of a video.
     

Share This Page