iPhone 5 and USB jack in GM vehicle- Podcasts only?

Discussion in 'iPhone' started by rprice54, Sep 21, 2012.

  1. rprice54 macrumors member

    Joined:
    Jul 24, 2011
    #1
    I have a GMC Sierra with the built in nav/radio system. It has a USB port in the center console for iPod connections. I can hook up the iPod/iPhone and browse the music and control everything with the head unit or my steering wheel controls. At least I could until I tried my new iPhone 5. Now when I connect it I can only listen to podcasts. It doesn't see any of my music. I've tried opening the music app, starting a song, and then connecting it to force the issue. When the phone is connected I get the "iPod accessory connected" screen on the phone and can't do anything with it.

    The podcasts play fine, so I know it can transmit audio. Why not my music. Worked great with my iPhone 4.

    Thanks for any help.
     
  2. Techbrute macrumors newbie

    Joined:
    Oct 1, 2012
    #2
    I have a 2010 GMC Sierra. I don't have the nav system, Just the CD player with XM, AUX, and USB. This morning when I plugged my iPhone 5 into the USB port, the "Connecting to USB" message stayed on the screen for an abnormally long time, and then it reported "No playable files exist..." I don't have any podcasts loaded on the device, but I do have a few Gb of music.

    The only related info on the web that I can find, besides this thread, is here:

    http://blogs.cars.com/kickingtires/...ork-in-your-car-we-may-have-the-solution.html

    To summarize the blog post, it didn't work, then he rebooted his phone, then it worked. The advanced troubleshooting technique he used (rebooting) did not work for me.

    Since I bought the truck in 2010, I have had the 3GS, 4, and 4S, with the current IOS at the time. All worked fine, including the 4S with IOS6 I was using up until this weekend.

    Anyone else having this experience?
     
  3. rprice54 thread starter macrumors member

    Joined:
    Jul 24, 2011
    #3
    I'm embarrassed to admit this. I didn't realize with iTunes match my old playlists that were on the iPhone4 wouldn't automatically download to my new phone when I set it up. After manually downloading all my music I'm back up and running.

    Doh!
     

Share This Page