iPhone 5 help

Discussion in 'iPhone' started by ConfusedChuck, Oct 21, 2012.

  1. ConfusedChuck macrumors newbie

    Joined:
    Oct 21, 2012
    #1
    Ok. So I just got the new iphone 5. When i plug it into my macbook pro, itunes says that i need iTunes 10.7 or later. So i go to download 10.7. But when i do that it says i need 10.6.8 (OS X mountain lion). so when i go to download that, it says that I need Mac OSX 10.6 or greater. I checked info about my mac and I have a 10.5.8. So how do I get 10.6 (which I believe is snow leopard??). Can someone please point me in the right direction here?
     
  2. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #2
    You can set up your phone without using iTunes now, there's no longer a need for it.
     

Share This Page