iPhone iPhone 5 / iPad 3 with Airport Extreme and WPA2 not working, WPA working

Discussion in 'iOS 6' started by ManuCH, Mar 3, 2013.

  1. ManuCH macrumors 6502

    Joined:
    May 7, 2009
    Location:
    Switzerland
    #1
    I have been noticing the following problem with my iPhone 5, as well as iPad 3, running iOS 6.1.2.

    When connecting via Wifi to an Airport Extreme A1408 (firmware 7.6.3), if the security is set to "WPA2 personal", it will eventually stop working after a while. The symptoms are that the Wifi signal is still shown (the "bars" are there), but no traffic flows at all. To make it work again, I have to switch Wifi off then back on on the iPhone/iPad.

    I have done some extensive tests on this. I have found out that:

    - Wifi stops working when the devices want to negotiate a lower speed (for example when going a bit further away from the Airport Extreme)
    - it happens on both 2.4 and 5 GHz
    - it happens with wide channels enabled or disabled
    - the multicast rate is irrelevant
    - it happens on all Wifi channels, when setting them manually

    Also, this is not a single device issue, because:

    - I have tried 2 different iPhone 5 as well as an iPad 3
    - I have tried 2 different Airport Extremes

    Now comes the interesting part: if I change the security to "WPA/WPA2 personal" (as opposed to WPA2 only), everything works perfectly again. This is 100% reproduceable.

    Does anyone else have this very same problem? I wonder if this is an Airport problem or an iOS 6.1.2 problem. On a different Wifi router (not an Airport), WPA2 only works fine.
     
  2. lexvo macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #2
    My iPhone4 and iPad3 are on iOS 6.1.2 and I don't have this problem. However I have the previous Airport Extreme and I have it still on FW 7.6.1

    I have read about problems with FW7.6.3, maybe downgrading is an option?
     
  3. ManuCH thread starter macrumors 6502

    Joined:
    May 7, 2009
    Location:
    Switzerland
    #3
    You are absolutely right! I downgraded to 7.6.1, and the problems disappeared. Now WPA2 only mode works perfectly. I will file a bug report with Apple. Even though this probably doesn't happen to everyone, it certainly does here, and they might be interested.
     
  4. Prime85 macrumors 6502a

    Prime85

    Joined:
    Mar 1, 2012
    #4
    This problem happened to me yesterday with mine and my wife's iphone 5. I have a TimeCapsule with a Airport Extreme used as a network extender. Nice to know i am not the only one that has this problem.

    ----------

    I just summited the problem to apple, Hopefully the more emails they get on this problem the faster they will fix it.
     
  5. xmaseve macrumors regular

    Joined:
    Oct 24, 2007
    #5
    I had this exact same problem with the iPhone 5 and a fifth-generation airport extreme base station. I went back to firmware 7.6.1 and my issues disappeared. Definitely seems like a problem with firmware 7.6.3...especially on the 5GHz frequency.
     
  6. Che Castro macrumors 603

    Joined:
    May 21, 2009
    #6
    http://www.marco.org/2013/05/21/aebs-wifi-downgrade

    I was having the same wifi problems ,so I downgraded the AirPort Extreme firmware using the guide in the link

    I will report back in a week too see if it works
     
  7. Che Castro macrumors 603

    Joined:
    May 21, 2009
    #7
    after one week of downgrading the firmware I have not had any wifi drops

    So downgrading the AirPort Extreme firmware fixes the wifi problems with iPads & iPhones

    I can't believe I went months with this problem , now I know not to upgrade the firmware right away when a new release comes out
     
  8. Che Castro macrumors 603

    Joined:
    May 21, 2009
    #8
    AirPort Base Station Firmware Update 7.6.4

    - Resolve an issue that may cause AirPort Time Capsule to report that the backup disk is in use
    - Resolve an issue that may cause an IPv6 Tunnel error
    - Resolve an issue that may intermittently cause a loss in Wi-Fi connectivity with iOS devices

    Note: This firmware update is for all 802.11n AirPort base stations.
     

Share This Page