iPhone 5 wouldn't play my music, anyone else have this happen

Discussion in 'iPhone' started by tigress666, Sep 28, 2012.

  1. tigress666 macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #1
    So I use my iPhone as an alarm usually with an app that lets me play my music on it to wake me up. Except today it didn't go off at the time I thought, or at least I thought that was it until I turned it on and noticed the alarm was going off but no sound was coming out.

    At first I checked sound level (that shouldn't be it, the alarm is good about playing even if the phone's sound is down or on mute, it goes by it's own volume setting). Even if it was it, that wouldnt' work cause the mute button was off and volume was at full.

    So I tried playing music through the music app. It wouldn't play any song I tried. I would press play and it would for a second start and then go back to not playing (Like it was acknowledging it wasn't playing the song but would refuse to play it).

    I restarted the phone and that fixed that.

    But seeing as I use my phone as an alarm, this is going to be an issue if it's not a one time thing (I need to trust it will wake me up so just cause restarting it makes it work again doesn't help me). I haven't encountered this in iOS 5 (one time the alarm did fail to go off ever, it's a reliable app mostly, but that time it was the app not going off). Is this just a random fluke or have other people encountered this?
     
  2. zafuquazar macrumors newbie

    Joined:
    Sep 28, 2012
    Location:
    Petaluma, CA
    #2
    Yes! This exact same thing happened to me today. All the same symptoms. I haven't tried restarting yet because I was hoping to find a solution...
    Verizon 32GB

    Do you think it is notable that it happened to both of us on the same day?
     
  3. AFDoc macrumors 68030

    Joined:
    Jun 29, 2012
    Location:
    Colorado Springs USA for now
    #3
    Maybe it found your choice of music objectionable!

    I had a similar issue but I suspect it is because I had my phone swapped out. After I physically hooked it up to iTunes all was well.
     
  4. zafuquazar macrumors newbie

    Joined:
    Sep 28, 2012
    Location:
    Petaluma, CA
    #4
    OK, i logged a support call with Apple for the issue. They apple tech didn't have anything like this in their system. I suggest you guys also enter a support ticket so that Apple is notified of the issue. FYI, my support case number for this issue is: 355354065

    I still have not rebooted my phone so i could troubleshoot. here is what i have found so far:

    FIRST ROUND:
    pandora - appears to play normally, but no sound out of speaker
    nightstand (alarm clock app) - alarm appears to work normally, but no sound out of speaker
    native music app - when i hit play, it flashes into play mode for an instant and then back to pause. no sound from speaker

    for all of the above, the mute switch and volume control has no affect.

    SECOND ROUND:
    i used the earphones (earPods) to make a phone call and could hear fine on the call. After i ended the call, and with the headphone still plugged in:

    music app worked normally and i heard the music through the earphones

    I unplugged the earphones and the music continued to play normally through the speaker!

    Then i tried Pandora and it does NOT work. I get a pop up error message that says: "Unable to Play - Pandora encountered a problem that paused the music. If the music won't play, try restarting Pandora or rebooting your iPhone".

    plugged in earphones. pandora still does not work.
    music app still works normally.

    quit pandora. restarted pandora with the earphones in and it worked.
    unplugged earphones and pandora works with the speaker.

    music app still works.

    now nightstand works. BUT even if i set it to play a SONG, when the alarm goes off it is with a TONE.

    CONCLUSION so far: I suspect either:
    1. Nightstand is not playing well with iOS6 (even though it has since i upgraded on the first day with my 4s and then continued to work fine with the iPhone 5 until today)
    2. something wrong with the headphone jack on the phone.
     
  5. tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #5
    I didn't test it that hard. I just assumed my alarm app, Alarm Clock Pro, wasn't playing because my iphone was refusing to play the MP3s (cause it behaved like yours did when you went into the music app) and since I had it set to wake up up to my MP3s it couldn't play them so it did nothing (I wish it did a tone like yours as a backup).

    A simple restart had the music app playing so I assumed all was well, I didn't test the alarm clock to see if it worked though (I'll do that right now).

    Seeing as two different alarm clock apps had the same problem, I don't think the problem is with the app. Also, I would suspect it has to do with MP3s on your phone vs. a sound problem since the music app refused to play them (It didn't just play and no sound came out) and Pandora (at least at first) played fine as Pandora from what I understand just plays streamed music, not stuff off your phone.

    Oh, and mine is an AT&T 64 GB, but I have a feeling this has more to do with iOS 6 than the phone...

    Edit: My alarm just went off like I set it to and did fine.
     
  6. tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #6
    It happened again and I tried the headphone trick and that worked. I think you are right that it is related to that but whether it is hardware or iOS I am not sure.
     
  7. tigress666, Oct 4, 2012
    Last edited: Oct 4, 2012

    tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #7
    Hey, favor to ask of you. I went to the apple genius bar today to see what they said. She said from what she can tell it's not with the hardware (but wasn't willing to totally rule that out, I refused an exchange though since she didn't think it was hardware).

    She suggested a clean install (Which due to having a lot of app info I really don't want to lose I don't want to do).

    But, maybe we can see what apps we both have in common on our phones that could be the problem (it's not your alarm app, mine is alarm clock pro so definitely not the problem there)?

    Anyways, I'll PM the list of apps I have on my phone. If you can either send me the list you have or mark the ones I send yu that you have also, that would be greatly appreciated. Nevermind, you aren't allowing PMs... well, if you want to get together to check to see what apps we have in common, reply here how I can contact you (I just don't want to make the list public to all honestly).
     
  8. zafuquazar macrumors newbie

    Joined:
    Sep 28, 2012
    Location:
    Petaluma, CA
    #8
    sorry, i hadn't realized i wasn't allowing PMs. i turned it on.

    but unfortunately i am completely swamped with work all day and night until next week when i take a vacation to mexico. i am just not going to have any time to troubleshoot witcha until after the 16th. sorry :(

    i am disappointed to hear that it happened to you again. it hasn't happened to me again yet, but i will be very disappointed when it does if it means i miss my alarm. has there been any new discussion about this issue online anywhere?
     
  9. Bricks macrumors newbie

    Bricks

    Joined:
    Jul 28, 2012
    #9
    Just got my new iPhone 5 today

    I have no sound in any of my apps. Is there a fix?
     
  10. Bricks macrumors newbie

    Bricks

    Joined:
    Jul 28, 2012
    #10
    Well I don't have sound in apps that I downloaded off the app store. The timer alarm works though.
     
  11. zafuquazar macrumors newbie

    Joined:
    Sep 28, 2012
    Location:
    Petaluma, CA
    #11
    no sound in most apps, but still sound from the alarm: that sounds like you have the phone set to mute mode. if that is the problem, flip the toggle switch above the volume buttons (unless you have remapped that to anti-rotation switch, in case you already know how to switch mute mode off :)
     
  12. tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #12
    Is fine. And yeah, I was hoping it was going to be a one off thing.

    Genius recommended me do a clean install and I'm just trying to avoid it. She said it's the first time she's heard of the problem. I'm not in a huge hurry as I have an ipad I can set the alarm to do the rooster call as a backup in case mine doesn't go off (just prefer to wake up to music. Today I didn't put on the backup alarm cause it was my day off).

    I'll PM ya if you can remember to reply back when you can. Have fun in Mexico.
     

Share This Page