iPhone 6 8.0.2 "unlocked" TMo on ATT suddenly stopped working on any network

Discussion in 'iPhone' started by reidconti, Oct 14, 2014.

  1. reidconti macrumors newbie

    Joined:
    Oct 6, 2008
    #1
    Anyone else having this issue? I'm working a case with Apple support, they've been helpful so far. It sounds like there's a possibility of a bug somewhere, because yesterday support made it sound like there are a handful of others facing this issue, wondering if anybody else here has seen it.

    Basically: Bought 6 from Apple online, full pop TMo phone, put my ATT SIM card in, upgraded straight from 8.0 to 8.0.2, worked great for a week, then saturday night it dropped off the network and hasn't been able to reach it since.

    Done several erase+restores through iTunes, both restoring as a new phone and from a backup, tried my ATT and TMo SIMs, no luck. Both SIMs get a signal in my 5s, nada on the 6. Checked with ATT to make sure my account looks fine, and of course I've talked to 3 people at Apple support and they've all looked through my account and everything and not seen any issues from their side (eg, it is DEFINITELY true that my phone is unlocked ;) Apple has gotten diagnostics from my phone.

    Anyway, yesterday morning they said to expect a reply from Engineering within a business day or so, so hopefully I'll get word today or tomorrow.

    The one thing I haven't tried is to find 8.0.0 software to see if that helps.. but like I said, it ran fine on 8.0.2 for about a week, so it's not like an upgrade broke it. Plus I don't want to complicate their troubleshooting at all.

    Also theoretically possible it's a hardware issue, I suppose, but it would be weird for it to fail suddenly -- eg, take it out of my pocket 1 minute and it works fine, take it out 10 mins later and it's a goner.

    Hopefully it's a software fix, I'm excited about using ApplePay and don't want to have to wait for a new phone shipment :) Fortunately I still have my unlocked 4s and 5s to use in the meantime.
     
  2. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #2
    I think all we can do at this point is take wild guesses, but maybe a carrier update pushed by AT&T didn't go as planned, and maybe bricked the baseband?

    In any case, I hate to say it, but if a restore isn't helping, and the SIM is working on other phones, then the only resolution might be to get it swapped out. :(
     
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    I believe ATT did push a carrier update, so that might be the smoking gun.
     
  4. Fantasigraphic macrumors 65816

    Joined:
    Mar 25, 2009
    Location:
    TN
    #4
    Try a restore setup as new but don't update Carrier Update. See if that works. If it does, like others said, there's your problem
     
  5. reidconti, Oct 14, 2014
    Last edited: Oct 14, 2014

    reidconti thread starter macrumors newbie

    Joined:
    Oct 6, 2008
    #5
    We'll see what Apple comes back with. Each time I restore and try both SIMs, I get a "carrier update?" prompt both when installing T-Mobile and ATT SIMs (one for each). It doesn't seem to matter if I accept or refuse the update, either way nothing works properly (as noted: maybe bricked baseband by ATT update).

    Any idea when this ATT update was pushed? Phone stopped working sometime between 22:00 and 23:00PST on Saturday October 11.

    I notice with the ATT or TMo SIM I see "ATT 17.1" or "T-Mobile 17.1" as my carrier. So they're both using the 17.1 baseband?

    I've got a stack of other (international) SIMs that I can plug in, and they all say CarrierName 17.0.

    Wonder if they'll be able to find a way for me to use the 17.0 baseband with ATT, if in fact that was the update. Anyone know if 17.1 was what was pushed recently?

    I imagine a clean restore still leaves me at 17.1 baseband, and the "carrier settings" are something else (minor configs) entirely?

    I wonder who all this affects. Obviously not all 17.1 recipients. Probably not all TMo-phone-on-ATT folks, because even that would have left a LOT of people with issues.

    update:
    fresh restore with no carrier settings update shows 17.0 for both TMo and ATT SIMs; still no signal though.

    update2:
    Rolled back to 8.0.0 showing ATT 17.0 / did not accept carrier update, and still no love.

    So I rolled forward to 8.0.2 and I'll stop messing with it until I get a solution from Apple. Unless I get bored and come up with a new idea ;)
     
  6. terraphantm macrumors 68040

    Joined:
    Jun 27, 2009
    Location:
    Pennsylvania
    #6
    Sounds like there may be a hardware fault with the baseband
     
  7. myztikal47 macrumors regular

    Joined:
    Dec 4, 2007
    #7
    I'm having this same issue, got my 6+ yesterday, updated to 8.0.2 as soon as I got it, but before I updated it, I played around with the phone for about an hour while it was on 8.0. Updated to 8.0.2, and ATT LTE signal starts up at 4 bars, then drops to 1 bar.

    LTE speeds are close to .2mbps down and .1mbps up. My brother has a Verizon version he's using with ATT and he doesn't seem to be having any problems at all. Luckily I bought 2 iPhone 6+'s, was just gonna return the other one, but I'm gonna open it up tonight and not update it to see how it performs.
     
  8. reidconti thread starter macrumors newbie

    Joined:
    Oct 6, 2008
    #8
    Different issue. I get "Searching" and "No Service". It completely fails to connect to the network, ever.

    Hope you get your issue sorted out though!
     
  9. myztikal47 macrumors regular

    Joined:
    Dec 4, 2007
    #9
    Is it possible to downgrade to 8.0? I'll try that instead of opening the other phone. The fact that it's gonna take me 2hrs to get all my crap loaded back on today is really gonna piss me off.
     
  10. zeeyo987 macrumors regular

    Joined:
    Sep 21, 2012
    #10
    looks like you tried everything, go take it to an apple store and get it swapped out
     

Share This Page