iPhone 6 Plus iMessage Not Working

Discussion in 'iPhone' started by makris0000, Oct 2, 2014.

  1. makris0000 macrumors member

    Joined:
    Jul 20, 2011
    Location:
    Clearwater Beach
    #1
    Hello,

    I just got my 6 Plus and I noticed that with iMessage, it is not sending messages through my phone number. It is sending them through my email instead. How do I fix this so iMessages will send through my phone number instead of through my email.

    Thanks.
     
  2. Snot Rox macrumors 6502

    Snot Rox

    Joined:
    Sep 16, 2014
    Location:
    SF Bay Area, CA
    #2
    Go through your messages settings and "send and receive" see if your phone number is checked. If not then check it so you'll receive iMessage to your number as well.
     
  3. makris0000 thread starter macrumors member

    Joined:
    Jul 20, 2011
    Location:
    Clearwater Beach
    #3
    It is checked for both the number and the email. When I have only the phone number checked it will not send the message at all unless I send it as an SMS.
     
  4. dcharleyultra macrumors 6502

    Joined:
    Sep 28, 2013
    #4
    My phone number is grayed out. What does that mean. (I'm not having any iMessage issues.)
     
  5. Clevans macrumors regular

    Joined:
    Dec 22, 2012
    #5
    my iMessage had to be reset last night. For some reason it said that my phone number was activating and wouldn't send as iMessage or SMS. I had to turn off iMessage and FaceTime, then go into General, Reset, and Reset Network Settings. Once my phone turned back on I went in and turned back on iMessage and FaceTime and it was back to normal, and I made sure only my phone number was picked to send and receive
     

Share This Page