alectric619

macrumors newbie
Original poster
Aug 31, 2012
4
0
It's been about 2 weeks since the new iPhones came out and still haven't had an update to fix the slow wifi problems, getting frustrated having an unusable phone
 

meraki1990

macrumors newbie
Oct 24, 2011
14
0
My plus also keeps on dropping Wi-Fi and then not able to find any..

Frustrating.
 
Comment

webbuzz

macrumors 68000
Jul 24, 2010
1,911
6,423
My plus also keeps on dropping Wi-Fi and then not able to find any..

Frustrating.

This just started happening to me today after a hard reset to correct battery usage/standby issue.

IOS 8.0.2
 
Comment

shook187

macrumors member
Sep 21, 2014
38
24
It's been about 2 weeks since the new iPhones came out and still haven't had an update to fix the slow wifi problems, getting frustrated having an unusable phone
I returned mine yesterday since I'm not married to iOS, I'm actually an Android guy... Unfortunately I really did like the phone and hopefully a fix will come in real soon and I'll jump back on board.. But I would seriously consider a Note 4 if a fix is not in by the time its release
 
Comment

AMTYVLE

macrumors 6502a
Sep 23, 2014
635
459
Treasure Coast, Florida
I returned mine yesterday since I'm not married to iOS, I'm actually an Android guy... Unfortunately I really did like the phone and hopefully a fix will come in real soon and I'll jump back on board.. But I would seriously consider a Note 4 if a fix is not in by the time its release

I had a Galaxy S4 since the day it came out (just switched to the iPhone6+) but my Galaxy was notorious for dropping Wifi - "Internet connection is unstable" message was popping up ALL THE TIME. I tried everything to stop it, factory resets on the phone, connecting to different WiFi's, a new modem, a new router - EVEN switched internet providers...nothing helped.

Galaxy S4 was a pain with WiFi - glad I'm done with that phone.

I have yet to notice any WiFi issues with my 6+.
 
Comment

alectric619

macrumors newbie
Original poster
Aug 31, 2012
4
0
Guys I just found a fix, went to tmobile and got the "free" cell spot router which is 802.11ac I believe dual band, got rid of my old dlink 802.11N router

Now I get 29mbps speeds in average, up from the average 12mbps speed I had

Hope this helps you guys!:)
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.