Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iPhone and iPad not showing up in iTunes with synch via wifi on new MBA

zen

macrumors 68000
Original poster
Jun 26, 2003
1,713
471
I've just switched from an iMac to a MBA with external monitor. I've shifted my iTunes library and have authorised the new computer in iTunes, etc.

Both my iPhone and iPad have the "synch via wifi" option selected. Both are on the same wifi network as the MBA (just like the iMac was).

However, neither device shows up in iTunes if I unplug the cable. With the cable plugged in, everything works as normal and I can synch. When I unplug the cable, the device disappears and iTunes can't see it.

With my iMac, both the iPad and iPhone were listed under devices, no matter where they were in the house, so long as they were on the wifi network.

I think I've been through every iTunes setting (the "prevent ... from auto-synching" is NOT ticked).

Running iTunes 10.5.3, Lion 10.7.2, and iOS 5.0.1. The MBA is in clamshell mode with the external monitor connected, and is on the wifi network without any problem.

Any ideas? Am I missing a step somewhere?
 

anthonymoody

macrumors 68030
Aug 8, 2002
2,734
807
I've just switched from an iMac to a MBA with external monitor. I've shifted my iTunes library and have authorised the new computer in iTunes, etc.

Both my iPhone and iPad have the "synch via wifi" option selected. Both are on the same wifi network as the MBA (just like the iMac was).

However, neither device shows up in iTunes if I unplug the cable. With the cable plugged in, everything works as normal and I can synch. When I unplug the cable, the device disappears and iTunes can't see it.

With my iMac, both the iPad and iPhone were listed under devices, no matter where they were in the house, so long as they were on the wifi network.

I think I've been through every iTunes setting (the "prevent ... from auto-synching" is NOT ticked).

Running iTunes 10.5.3, Lion 10.7.2, and iOS 5.0.1. The MBA is in clamshell mode with the external monitor connected, and is on the wifi network without any problem.

Any ideas? Am I missing a step somewhere?

Just out of curiosity have you tried with the MBA open as opposed to clamshell? Maybe something weird about that interaction.

In not, try de-selecting wifi sync. Quit/reopen itunes and hard reset your ipad while doing so. Connect wired. Sync. Reset your iPad, again quit/reopen iTunes. Reconnect wired, and now select wifi sync. See if that doesn't do the trick.
 
Comment

anthonymoody

macrumors 68030
Aug 8, 2002
2,734
807
That worked, thanks!


You're welcome and glad it worked! I have found that many pairing type errors can be remedied with a handful of quit/reopen/reset type activities.

I have problems with the Remote app and iTunes on my iMac sometimes not playing nicely. Haven't been able to solve it permanently but this type of thing usually helps for a time.

I actually saw the solution above posted in another forum some time ago. Anyway, glad it worked!
 
Comment

star-affinity

macrumors 65816
Nov 14, 2007
1,358
631
You're welcome and glad it worked! I have found that many pairing type errors can be remedied with a handful of quit/reopen/reset type activities.

I have problems with the Remote app and iTunes on my iMac sometimes not playing nicely. Haven't been able to solve it permanently but this type of thing usually helps for a time.

I actually saw the solution above posted in another forum some time ago. Anyway, glad it worked!

Worked for me too! Strange, I wonder exactly which of the steps it is that actually solves it. Sounds strange that you have to do the restart of the iOS device twice, no?
 
Comment

Sakurambo-kun

macrumors 6502a
Oct 30, 2015
510
477
UK
Just out of curiosity have you tried with the MBA open as opposed to clamshell? Maybe something weird about that interaction.

In not, try de-selecting wifi sync. Quit/reopen itunes and hard reset your ipad while doing so. Connect wired. Sync. Reset your iPad, again quit/reopen iTunes. Reconnect wired, and now select wifi sync. See if that doesn't do the trick.

I just ran into this problem and your solution still works! Thanks!
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.