iPhone Dock gives "This accessory is not made to work with iPhone" error

Thanatoast

macrumors 65816
Original poster
Dec 3, 2002
1,006
139
Denver
Except that the aformentioned accessory is the iPhone dock and it's plugged into my computer. My iPhone sync'd okay, but it's still an annoying problem. Anyone else getting this strange error?
 

Teh Don Ditty

macrumors G4
Jan 15, 2007
11,308
5
Maryland
Except that the aformentioned accessory is the iPhone dock and it's plugged into my computer. My iPhone sync'd okay, but it's still an annoying problem. Anyone else getting this strange error?
I had that problem when I used the ac adapter with my dock. I took it the genius bar (where they couldn't reproduce it, but I had pictures of it just in case). They replaced the AC adapter, cable and dock for me on the spot.
 

jt2ga65

macrumors regular
Jul 1, 2007
197
0
Has anything that sends that message actually not worked, though? My ipod2car works perfectly well with the iphone, just gives the message. A guy I work with got the message from a Apple USB cable, while plugged into his computer. I didn't realize that there was a difference between the cables, as none of mine do that.

-jt2
 

hulksmash

macrumors newbie
Nov 26, 2007
1
0
Clean your doc and cord

This problem happened to me. Finally found on a Apple forum that lint can build up on the connector, dock, or cable and cause this error to pop up all time. Try cleaning the connector using keyboard air spray or was the cable and connector pieces. That should do the trick.
 

atchius

macrumors newbie
Feb 21, 2007
4
0
My experiences

I had the same problem. It was an actual problem for me, though, because if the iPhone doesn't recognize that it's in a genuine iPhone Bluetooth Headset Dual Dock, then the headset won't charge or sync (the iPhone manages the headset's connection when they share the same dock). I spent about five minutes with a needle cleaning out the dock and the dock connector. I also blew on them a lot. Problem solved. I would assume if certain pins aren't making contact, the iPhone's not sure what it's plugged into—but as long as the two or three pins carrying the power supply make contact, it will still charge correctly.

So, in short, just clean it a little. It wasn't too bad.
 

josielinnea

macrumors regular
Dec 15, 2007
226
1
Stockholm
Oh yeah? Mine does it randomly. Throughout the day. With nothing connected.
Mine too. It's the most annoying piece of crap-message... does yours also turn off the "speaker" sounds when the message appears? IE ipod-music will stop but it will still ring if someone calls you.
 

SAFC2403

macrumors member
Nov 22, 2007
66
0
Sunderland, UK
Mine seems to stop syncing or charging and is followed by the "usb device not recognised" in windows.

Have given it a blast of compressed air and a rather large chunk of fluff just flew out!!
 

mainstreetmark

macrumors 68020
May 7, 2003
2,228
293
Saint Augustine, FL
Mine too. It's the most annoying piece of crap-message... does yours also turn off the "speaker" sounds when the message appears? IE ipod-music will stop but it will still ring if someone calls you.
Yep. That's the one. And sometimes, when someone does call - no sound comes out of the phone's ear speaker.

I'd take it back to Apple, but THIS is a replacement I just got 1.5 weeks ago. I think it has some funk in the dock connector.
 

gummy

macrumors newbie
Apr 30, 2008
1
0
Mine too. It's the most annoying piece of crap-message... does yours also turn off the "speaker" sounds when the message appears? IE ipod-music will stop but it will still ring if someone calls you.
Exactly the same as me, I'm gonna have to claim it on my home insurance because i have no warrenty as its unlocked. :eek:
 

daver11

macrumors regular
Feb 11, 2005
123
0
Phoenix, AZ
Mine too. It's the most annoying piece of crap-message... does yours also turn off the "speaker" sounds when the message appears? IE ipod-music will stop but it will still ring if someone calls you.
Me, too (no "speaker" sound as well). This message keeps popping up with NOTHING connected (just started yesterday). My phone is NOT jailbroken and is 100% standard. I tried blowing the dust off the connectors on the bottom and out of the headphone jack – no luck. However, the phone operates normally otherwise, and since I am buying a 3G on the 11th...
 

bennybeige

macrumors newbie
Aug 5, 2008
5
0
Me, too (no "speaker" sound as well). This message keeps popping up with NOTHING connected (just started yesterday). My phone is NOT jailbroken and is 100% standard. I tried blowing the dust off the connectors on the bottom and out of the headphone jack – no luck. However, the phone operates normally otherwise, and since I am buying a 3G on the 11th...


Yep all sounds too similar to the problems i'm having.

So should I persist with the cleaning or send it back for warranty repair?

Anyone else having problems with a delay on the unlock/answer calls slider at the bottom? Not sure if this problem is related but my unlock slider doesn't always want to move, sometimes for a few seconds.

I have also noticed that my iphone does not like to stay turned off. Would this be because of dirt on the connection pins?
 

ttech10

macrumors 6502
May 16, 2008
379
0
I get the message when I plug it into my car. I use thing from Best Buy that plugs into the dock on the iPhone and the AUX plugin on the stereo. Everytime I plugged in my old iPhone (and the 3G) it says it gives the message and asks to turn Airplane mode on, of course I don't, and it still works fine.
 

jonparkes

macrumors newbie
Aug 4, 2008
1
0
I too have the same problem,

I've tried everything with my iphone to get rid of the message...

'This accessory is not made to work with iPhone'

This happened after I was in the pub and a friend knocked over a pint near my phone. Yes my fault for leaving my iphone on the table near our drinks.

I've tried cleaning the conductors, docking station etc and nothing.

I will be checking this everyday to see if anyone has found a solution!!!

:apple: =)
 

mdkrebs11

macrumors member
Jul 14, 2008
45
0
I too had some water damage on my phone. Everything was a little buggy for a day but it all went back to normal once it dried out. Everything except this Accessory Error message. I have tried everything to clean the connector at the bottom of the phone (3G) - compressed air, rubbing alcohol, everything. After the rubbing alcohol it worked for a few days so I thought I had the problem licked. But today it started up again. Every few minutes the error message pops up and sound won't work out of the speakers because it thinks it is plugged into something. It really sucks. I don't think there is a way to fix it. Unfortunately, because of the water indicators being pink, I'm sure I can't exchange it for a new one so looks like I'm going to be out 5 bills. Anyone figure out a sure fire way to fix this problem yet? Seems to happen on 1st gen and 2nd gen phones alike.
 

NiroshanMan

macrumors 6502
Jun 25, 2007
348
0
damn this warning is annoying. how does the iPhone know that the accesory is not made for it. Why can't they disable it, if the iPhone works with it then why do they need a warning? I use my old iPod docks, but the warning keeps coming everytime i plug itin...
 

davidlinker

macrumors newbie
Aug 6, 2008
1
0
Unfortunately, because of the water indicators being pink, I'm sure I can't exchange it . . . .
Where are these indicators? My phone ***may*** have gotten wet at one point - we do live on a water infested planet - but I get this darn message all the time as well, and it is getting pretty frustrating.
 

chaotixk

macrumors newbie
Jul 15, 2008
3
0
Where are these indicators? My phone ***may*** have gotten wet at one point - we do live on a water infested planet - but I get this darn message all the time as well, and it is getting pretty frustrating.
On the 3G, inside the headphone jack, underneath the dock connector, and inside the phone (there should be two round stickers). There could be more indicators but this is from what I gathered after my GF dropped hers in water. On a side note, still trying to get that working but she's probably SOL. LOL.
 

nati47

macrumors newbie
Aug 6, 2008
5
0
FInally Solution

Except that the aformentioned accessory is the iPhone dock and it's plugged into my computer. My iPhone sync'd okay, but it's still an annoying problem. Anyone else getting this strange error?
heres how i solved it.... when i turned off my phone it would come back up in like 40 seconds... i have an airbrush machine... a blower is ok but .. airbrush is more precise.... i just blew hair into the doc connecter for about 10 seconds on each side.. then blew air side to side.. incase it was something caught it would blow it away... my compresor is bout 60psi.. doesnt matter how much u use... but its good to use an airbrush cause its thinner n goes directly to the problem.. when i turned my phone on .. it was gone .. no more of that annoying sign.... i believe i had a drop of water from washing dishes .. just keep at it... hope this helps u guys:):):):)