Iphone firmware 2.2.1 and quickpawn not updating from 2.2 to 2.2.1

Discussion in 'iPhone Tips, Help and Troubleshooting' started by markm75, Mar 24, 2009.

  1. markm75 macrumors member

    Joined:
    Nov 25, 2008
    #1
    I've downloaded quick pawn 2.2.5.. i have the iphone1,2_2.2.1_5h11 file...

    I am able to connect my phone which has 2.2 (jailbroken) already on it..

    Run through all the steps, i get all the logos and the installing screen, but at the end, when i check in settings for version its still at 2.2

    I'm at a loss here..

    Any thoughts?

    Thanks
     
  2. lopezpm macrumors newbie

    Joined:
    Mar 17, 2008
    #2
    It's not meant to upgrade. It's only meant to jailbreak the presently installed version. Upgrade through iTunes first then Jailbreak with quickpwn.
     
  3. markm75 thread starter macrumors member

    Joined:
    Nov 25, 2008
    #3
    Wont i lose my settings and jailbroken apps if i do this?

    Thanks
     
  4. lopezpm macrumors newbie

    Joined:
    Mar 17, 2008
    #4
    Yeah, you have to reinstall everything again. Just make a list of everything installed and redo it. It's not too bad.
    Come to think of it, I haven't tried this program myself but it does what you want.
    http://cydia.thebigboss.org/moreinfo/AptBackup.php
     
  5. wilmer007 macrumors member

    Joined:
    Oct 12, 2008
    #5
    Umm theres a backup feature in iTunes. When i went from 2.1 to 2.2.1 i backed up and retrieve all my apps and stuff without a problem.
     
  6. lopezpm macrumors newbie

    Joined:
    Mar 17, 2008
    #6
    does that include all your jailbroken apps?
     
  7. wilmer007 macrumors member

    Joined:
    Oct 12, 2008
    #7
    Umm i don't really remember but i think the jailbroken apps were not backed up. You can't really ask for much it's better to get half the backup restore then nothing. As long as it backups your apple store apps you gotta be somewhat of a happy camper.
     
  8. lopezpm macrumors newbie

    Joined:
    Mar 17, 2008
    #8
    That's why I suggested aptbackup. The appstore apps are already in your iTunes and in your backup.
     
  9. markm75 thread starter macrumors member

    Joined:
    Nov 25, 2008
    #9
    Ok, so i ran through and ended up doing the following, still with no luck:

    I ended up doing a restore on the iphone.. after the restore it updated me to the apple version of 2.2.1 per the about screen..

    So i then ran quickpwn 2.2.5, it found the firmware at C:\Users\admin\AppData\Roaming\Apple Computer\iTunes\iPhone Software Updates\iPhone1,2_2.2.1_5H11_Restore.ipsw

    Everything appeared to be going great, the screen on the iphone changed to show it was being installed..

    but after it was done installing, i dont have cydia icons and no way to verify its jailbroken.

    I selected cydia and installer on the quickpwn screen too..

    I'm not sure why this just isnt working for me.

    I'm on vista x64.

    Thanks in advance
     
  10. lopezpm macrumors newbie

    Joined:
    Mar 17, 2008
    #10
    Try it again. It works on Vista x64, that's what I have at home. I just did it to my wife's phone.
    Download Quickpwn from here, http://theiphoneproject.org/windows/QuickPwn-225-2.zip
    Download your Firmware from here, http://thebigboss.org/guides/iphone-firmware-files/
    Make sure you select the right one. Follow the guide from here,
    http://thebigboss.org/guides/quickpwn-windows/
     
  11. markm75 thread starter macrumors member

    Joined:
    Nov 25, 2008
    #11

    I finally got things working..

    Here are the steps that i had to do in case anyone else is interested:

    1. Restore the iphone via the itunes restore button (consequently updating to the latest fw version from apple)
    2. Do not restore settings, or setup the iphone
    3. Run quickpwn, browsing to the firmware in a location other than c:\users (not sure if the alt location mattered or not)
    4. Do not restore a backup from itunes (settings)
    5. Reinstall everything.. over the course of hours ;)

    #4 was particularly the issue.. as i'd get through #3, cydia would be listed.. i would then (mistakingly?) think i could restore a backup (settings) to get my settings back at least, and when i would do this, i would lose the cydia icon for some reason, though some jailbroken apps remained and worked (odd?)

    So i gave up on being able to restore settings and just started all over..

    This will suck, as if there is no way to restore settings, ill have to do it all again come summer with v3.0, unless there is some secret way to avoid starting all over.
     
  12. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #12
    Were you using Categories or SBSetting's "dock" function? If so, you need to take those apps out of the folders/dock, then make a backup, then restore from that backup.

    Also, I've heard that if you are missing icons after restoring from a jailbreak, you can enable, then disable, usage restrictions in settings, and this will bring back the icons. But I've never tried this myself.

    My advice is to never place Cydia in a folder/dock or otherwise hide that icon.
     
  13. markm75 thread starter macrumors member

    Joined:
    Nov 25, 2008
    #13
    Ah this explains it, yep i was using both sbsettings and the categories program..

    Had i not been, i guess this would have been fine, or had i moved them out of there first, from what you indicate..

    I'll be ready for 3.0 though :)

    Thanks for the help again
     

Share This Page