iPhone iOS 5 Double new mail sound

Discussion in 'iPhone' started by isaaclimdc, Nov 21, 2011.

  1. isaaclimdc macrumors 6502

    isaaclimdc

    Joined:
    Jun 28, 2009
    Location:
    Pittsburgh, PA
    #1
    Hey guys,

    I've recently noticed a very very strange bug on my iPhone 4 on iOS 5. When I get a new email nowadays, my iPhone makes both the "Ding" sound (which is the normal new email sound), AS WELL as the SMS "Trio" sound right after. This is very weird and frankly quite disturbing since I keep thinking I'm getting an SMS that I don't see.

    Anyone experience this as well? If no one knows a fix I'm just gonna have to restore everything (again) :(
     
  2. marcypark macrumors newbie

    Joined:
    Aug 5, 2009
    #2
    I have had the same exact issue every since updating to 5.0.1 and have been searching for a solution ever since. Some people have recommended doing a hard restart (or whatever it's called) by pressing the home and sleep buttons at the same time until the phone restarts, but it did not work for me, neither did simply resetting the phone. I have read where simply changing the tone works, but that is a no go for me as well. Some have said genius bar employees are changing out phones (mostly 4s models) because they feel that it is a hardware issue, but to me it seems software related as I never had the issue before iOS5. I am thinking that it is somehow related to the notification system and not iCloud as I have read. When I turn off syncing mail to iCloud, the problem still exists. However, when I turn off the email notification center, the problem stops. Therefore, there must be some bug on how new emails are handled in notification center. Does anyone have a solution other than turning off email notifications?

    (FYI - Turning off email notifications just means that the preview will not show up on the lock screen. It will just make a noise or vibrate.)
     
  3. isaaclimdc thread starter macrumors 6502

    isaaclimdc

    Joined:
    Jun 28, 2009
    Location:
    Pittsburgh, PA
    #3
    Wow awesome that I'm not the only one with this problem!

    Wait so doing a complete clean restore does not solve the problem for you? Or are you restoring from backup?
     
  4. marcypark macrumors newbie

    Joined:
    Aug 5, 2009
    #4
    I haven't tried that yet. And I've been playing around with turning off notification center for email and it was a very temporary fix. I just sent myself another email and its back.
     
  5. isaaclimdc, Nov 21, 2011
    Last edited: Nov 21, 2011

    isaaclimdc thread starter macrumors 6502

    isaaclimdc

    Joined:
    Jun 28, 2009
    Location:
    Pittsburgh, PA
    #5
    I'm going to do a restore from backup now and see how that goes. I'll report back :)
     
  6. marcypark macrumors newbie

    Joined:
    Aug 5, 2009
    #6
    Actually having time to play with this issue makes me even more curious. When I toggle notification off and on, the very first email received will not make the double tone. However, every subsequent email will, but the tones are very far apart. This is very unlike what has been happening in the past. Typically the tones are immediately after each other. So maybe toggling this resets some sort of timing that gradually decreases the interval time between tones as the days progress. Color me confused :confused:
     
  7. isaaclimdc thread starter macrumors 6502

    isaaclimdc

    Joined:
    Jun 28, 2009
    Location:
    Pittsburgh, PA
    #7
    Well, seems like a clean restore then a restore from backup did the trick! Only the normal new email sound is left. I suggest you try that then.. takes some time, but totally worth it to rid yourself of that frustrating double tone!
     
  8. marcypark macrumors newbie

    Joined:
    Aug 5, 2009
    #8
    Here is a video I just posted on YouTube that shows what isaaclimdc and I are talking about:

    http://www.youtube.com/watch?v=3nlK6slE8sU

    ----------

    Will do! Post if it starts to occur again. I have a feeling that this might be a temporary fix, but lets hope for the best.
     
  9. BFG86 macrumors 6502

    Joined:
    Oct 14, 2011
    #10
    I'm having that issue too....

    just found there's a setting that says repeat alert. Mine is set to once. i'm going to change it to never....

    This repeat alert setting only shows up under messages that i've found so far
     
  10. marcypark macrumors newbie

    Joined:
    Aug 5, 2009
    #11
    That repeat alert is only for text/iMessages, not emails. Turning that off will not solve the double email sound as it is independent of the email system.
     
  11. galenmd macrumors regular

    Joined:
    Sep 11, 2008
    #12
    I am getting a repeat alert with voicemails. Is there a setting for that, or is it the same bug?
     
  12. marcypark macrumors newbie

    Joined:
    Aug 5, 2009
    #13
    A complete restore seems to have corrected the issue. I will update the post in a few days to provide an update.

    ----------

    I'm not sure. I've looked for a setting but can't find one. I hope a restore didn't just transfer the problem from one alert to another. But if I had my choice, I would prefer this annoying behavior to be on voicemail rather than email. I hope 5.0.2 fixes this.
     
  13. marcypark macrumors newbie

    Joined:
    Aug 5, 2009
    #14
    ...and this morning the double mail sound came back. So, no resolution on my phone.
     
  14. ah123 macrumors regular

    Joined:
    Jul 5, 2011
    #15
    Strange - I've been getting that, too, but thought it was related to the GFail app I downloaded. Not sure if it's that or the bug you're describing.
     
  15. actpa macrumors newbie

    Joined:
    Nov 24, 2011
    #16
    I also had this issue, and think it may be related to the gmail app. Try going to "settings->notifications->gmail" and turn off "sounds"
     

Share This Page