iPhone Shows Incorrect Language (Snapchat).

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ncbetz, Jan 15, 2017.

  1. ncbetz macrumors 6502

    ncbetz

    Joined:
    Jan 9, 2016
    Location:
    Texas, USA
    #1
    Hi,

    I have had this issue one other time and it was when I was trying out crossy road. The text is in some other language (I assume chinese)? Anyone know how to fix it? I clicked the "Support" button on SC and this popped up:
    IMG_4742.PNG

    I clicked the share icon on crossy road and it did same thing. I would just change the language on that page but it is all in chinese or whatever. The rest of the SC app is in english.

    I would appreciate all help.

    Noah
    --- Post Merged, Jan 15, 2017 ---
    Basically, I am looking for a place in settings where I may have tricked my devince into thinking that is my language.
     
  2. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    Well, the language portrayed is Japanese not Chinese but I suppose that doesn't matter since it's not in English. Have you tried removing the Snapchat app and then reinstalling it?
     
  3. ncbetz thread starter macrumors 6502

    ncbetz

    Joined:
    Jan 9, 2016
    Location:
    Texas, USA
    #3
    Yes, it hasn't changed anything. I also tried doing that for Crossy road or whatever it's called.
     
  4. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #4
    I just checked with the App Store and it looks like the Snapchat app comes in a multitude of different languages. I would delete it and then download it again and reinstall. It is strange because it should have downloaded to your iPhone the first time in English by default. But who knows, maybe it thought you were in Tokyo.
     
  5. ncbetz thread starter macrumors 6502

    ncbetz

    Joined:
    Jan 9, 2016
    Location:
    Texas, USA
    #5
    Wait, does it change your language / app store based off your location? Also I am reinstalling again.
    --- Post Merged, Jan 15, 2017 ---
    Okay, so I removed the app and signed in. The support page is still in Japanese. I know this cannot be SC only as it happened with other apps. I am not sure what to do.
     

Share This Page