Iphone stuck in Recovery mode cant go into DFU mode to restore..

Discussion in 'Jailbreaks and iOS Hacks' started by RyuuShin, Sep 26, 2011.

  1. RyuuShin macrumors newbie

    Sep 25, 2011
    Hi, well my iphone 4 is stuck in recovery mode and i don't got any shsh so i wanna get it to 4.3.5 to use it but i need to be in DFU mode.. now the problem is whenever i connect my iphone to my pc it turns on. When i try to enter DFU mode it won't go, the screen turns black and after about 7~10 seconds the apple logo comes on and if i release the sleep/wake button it goes to the screen with the usb and itunes logo.. So i can't go into DFU mode..
    But whenever it's not connected to my PC im able to go into DFU mode..
  2. MrThompsonR macrumors 6502


    Dec 15, 2009
    If you're getting the "Connect to iTunes" message, you should be able to "update and restore to the lates OS." This of course wipes your phone and puts 4.35 on it and once it reboots it can/ will copy all your files/ media from your iTunes library... I lost my 4.3.3 J/B but I'll take a working 4.3.5 over a "bricked" 4.3.3 anyday. I turned off my land line so I need a reliable/ working phone... I'll try J/B'g again(maybe) after 5.0 comes out followed by a J/B.
  3. mastermini macrumors newbie

    Sep 27, 2011

    I have the same problem, well first i tried to install ios 5 beta 7 activated and after i installed it i got thru but i had another problem i forgot ro hactivate it using snowbreeze and now i hactivated it and dried to restore it using itunes and it went fine but in the end when my iphone 4 rebooted got stuck to recovery mode loop i have used all methods to get it out of recovery mode but it doesnt work, i have tried to restore to original ios 4.3.5 but it doesnt work it eather i get error mesage 1604, i have tried to restore in onther computer but same problem, some guides says that have to put iphone in DFU mode first but the problem is i cant get it in DFU, it allways will get stuck in recovery mode.
  4. JunkyDog macrumors 6502

    Sep 17, 2011
    Error 1604: This error is often related to USB timing. Try changing USB ports, uninstalling and reinstalling USB ports, and other available USB troubleshooting steps (troubleshooting USB connections, device not recognized properly, computer won't recognize a FireWire or USB device). If you are using a dock, bypass it and connect directly to the white Apple USB dock connector cable. If the issue persists on a known-good computer, the device may need service.

    If the issue is not resolved by USB isolation troubleshooting, and another computer is not available, try these steps to resolve the issue:

    1. Connect the device to iTunes, confirm that the device is in Recovery Mode. If it's not in Recovery Mode, put it into Recovery Mode.
    2. Restore and wait for error 1604.
    3. When prompted, click OK.
    4. Close and reopen iTunes while iPhone remains connected.
    5. iPhone should now be recognized in Recovery Mode again.
    6. Try to restore again.

    If the steps above do not resolve the issue, try restoring using a known-good USB cable, computer, and network connection.
  5. mastermini macrumors newbie

    Sep 27, 2011
    I just fixed my problem after fighting with the iphone 4 and couple of different laptops hehehe, well actually i think it is all about timing to get the iphone in recovery mode, I used iFaith to help me get in DFU mode and I dont know what happened but I followed the instructions on iFaith and woila the iphone entered the DFU mode and then I restored the IOS4.3.5 after that i jailbroke it using redsn0w 0.9.8b5, this is a teathered jailbreak so i had again some problems when i restored my back up i tried to put it in DFU mode using redsn0w instructions and i didnt get the timing right sometimes so i used again iFaith and when i got it in DFU I unnplugged the cable fast from the computer and then I run redsn0w and booted the iphone 4, I had also the nevest version of redsn0w and that one didnt work for me it just hang when tried to jailbreak the phone or just boot the iphone 4 so i had to use redsn0w 0.9.8b5 and the redsn0w.exe was placed in my C: drive directly.

    I hope that this info will help someone.
  6. JunkyDog macrumors 6502

    Sep 17, 2011
    i will ask you if you have used Tiny Umbrella and saved your SHSH with cydia server, if so, tell me what blobs you have saved there, i was lucky enough to have shsh for 4.3.3, and downgraded mine to v4.3.3, and now i have a fully untetheret jailbrak that works.

  7. kinaan89 macrumors newbie

    Sep 21, 2011
    Hey there
    My iphone 4 also is stuck in recovery mode
    i cant restore or update i tried ifaith to put the phone in DFU mode then tried restoring to an older firmware or updating both ways it didnt work in the middle after exctracting and restoring it stops and an error message 3194

Share This Page