iPhone won's be detected in iTunes 10.5.6 DFU mode fix broke it?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ethan028, Apr 4, 2009.

  1. ethan028 macrumors 6502a

    ethan028

    Joined:
    Apr 4, 2009
    Location:
    San Francisco, CA
    #1
    Well, i applied the 10.5.6 DFU mode fix to my macbook pro early 2008. And after the restart everything worked fine even my USB ports! But when i plug in my iPhone it only gets reconized under iPhoto! But is charging, and is not reconized under iTunes or xCode. So i thought "Odd" so i googled my problem couldent find anything until i cam over an article in gizmodo. it was instructions on how to fix the USB port problems on the 10.5.6 DFU mode fix so i tryed it out. And guess what when i was done I HAD THE SAME EXACT PROBLEM. I have bootcamp on my macbook and its reconized under windows 7 fine. So it's not my iPhone, i tryed reinstalling itunes CLEAN INSTALL i mean i deleted every single folder related to it Even the Mobile Device Support! Im out of ideas here i even downloaded the 10.5.6 combo update and installed it Still no go so i beg of you please i need my iPhone reconized under iTunes on my mac i hope you guys can help.

    Thanks.

    -Ethan
     
  2. DiSFLyLaTiNa macrumors regular

    Joined:
    Jan 8, 2009
    #2
    try using a usb hub. I had the same problem and i was getting so FRUSTRATED and then i connected it through a usb hub and it works in DFU mode. because with 10.5.6 the phone doesn't go completely into DFU mode you should try using the usb hub.
     
  3. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #3
    Follow the dfu mode fix listed on the Dev Team Blog.

    linky


     
  4. DiSFLyLaTiNa macrumors regular

    Joined:
    Jan 8, 2009
    #4
    that's too much stuff to do. just connect your phone through a usb hub and it'll work. and you dont have to recode anything.
     
  5. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #5
    It doesn't even take 10 minutes. And you don't have to spend money on a usb hub. ;)
     
  6. ethan028 thread starter macrumors 6502a

    ethan028

    Joined:
    Apr 4, 2009
    Location:
    San Francisco, CA
    #6
    Thanks for the responses guys! its just i dont want to do Anything DFU mode anymore all i want is itunes and xcode to detect my iphone GAH! i will try the idea posted though and get back to you guys.
     
  7. ethan028 thread starter macrumors 6502a

    ethan028

    Joined:
    Apr 4, 2009
    Location:
    San Francisco, CA
    #7
    Also thanks for the reply jmann! i tryed your instructions, but infortunatly it didn't work my iphone still wont appear in itunes or in xcode but it will in iPhoto god this is making me angry.
     
  8. ethan028 thread starter macrumors 6502a

    ethan028

    Joined:
    Apr 4, 2009
    Location:
    San Francisco, CA
    #8
    I tryed your fix again jMan and now im getting 1600 errors.
     
  9. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #9
    Try a restore with "restore mode"

     
  10. ethan028 thread starter macrumors 6502a

    ethan028

    Joined:
    Apr 4, 2009
    Location:
    San Francisco, CA
    #10
    Thanks jmann restoring now! i will see if it detects it in a second!
     
  11. ethan028 thread starter macrumors 6502a

    ethan028

    Joined:
    Apr 4, 2009
    Location:
    San Francisco, CA
    #11
    SUCCESS OMG IM SOO HAPPPYY!!!! THANKS JMAN! i will be sure to rep you!
     
  12. alexus macrumors member

    Joined:
    Jul 12, 2006
    #12
    i installed iousbfamily327.4.0log.dmg first by accident, now it wont let me install iousbfamily315.4.1log.dmg ... any ideas how I can do it?

    i also tried through ext hub, still no go... ;-(
     

Share This Page