iPhone won't stay connected to WIFI at home

Discussion in 'iPhone' started by jturn241, Oct 7, 2012.

  1. jturn241 macrumors member

    Joined:
    Mar 11, 2011
    #1
    My iPhone 5 won't automatically connect to my WIFI at home. I have to go in an manually connect. Sometimes it stays connected for a few hours others it disconnects when I lock the screen. My moms iPhone 4 which is on IOS6 doesn't have this problem.

    This also only happens when I am at home. At work and other known networks it automatically connects with no issue
     
  2. Vundu macrumors 65816

    Vundu

    Joined:
    Jun 10, 2009
    Location:
    Manchester, UK
    #2
    Same here. Quite common issue by all the posts about it.
     
  3. SSonnentag macrumors member

    Joined:
    Jan 18, 2006
    Location:
    Yuma, Arizona, USA
    #3
    I'm having the same problem. Wi-Fi is 10% speed when it is connected. Ping times are very long 200-400 ms. Wi-Fi disconnects often and doesn't want to reconnect at times. 3G is much faster. My iPhone 4s had no issues with Wi-Fi.
     
  4. doasis23 macrumors regular

    doasis23

    Joined:
    Aug 23, 2012
    #4
    Go into wifi settings. Go to other. Type in name of router and which type of security it's using and type in password.

    Worked for mine. Wouldn't stay connected and had to renter password each time. Haven't lost connection since.
     
  5. jturn241 thread starter macrumors member

    Joined:
    Mar 11, 2011
    #5
    I can't use that method as my router doesn't require a password
     
  6. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #6
    You should add a password to your router ASAP.

    It's not just a matter of preventing people from wasting your bandwidth; someone could use your connection for illegal activities (scamming people, child porn, etc.) and when the cops come to knock on a door it will be yours.

    Even if you're completely innocent, it's not something you want to deal with.

    Set a WPA2 password, and make it a good one.
     
  7. AirForceOne macrumors member

    Joined:
    Jan 16, 2011
    #7
    Thanks for this man. My iPad Mini was exhibiting the same behavior and this fixed it. Thanks again, was driving me nuts!
     
  8. doasis23 macrumors regular

    doasis23

    Joined:
    Aug 23, 2012
    #8
    No problem glad it worked for you . Drove me crazy.
     

Share This Page