iPhone4 Will only work plugged into speaker dock

Discussion in 'iPhone' started by Katie785, Dec 30, 2011.

  1. Katie785 macrumors newbie

    Joined:
    Dec 30, 2011
    #1
    I dropped my iPhone 4 in water for a bout 4 seconds. It turned off (it died) I pulled out the SIM card, put it in rice for 72 hours... now it turns on but only when it's plugged into a JBL speaker dock. It says "slide to configure" but I obviously cannot do that from the dock. When I plug it into my Macbook Pro, it does not come on and the macbook does not read that its there. It's weird that it will get power only when in the dock.

    I tried turning it offf while in the dock and restarting it. It comes back on, but only to die when i take it out the dock.

    Any thoughts on a fix? Do you think the battery connection is burnt out? I have a toolkit overnighted that will be here tonight and plan on taking it apart and cleaning everything with some WD40 to get rid of any corrosion.
     
  2. trozau macrumors regular

    trozau

    Joined:
    Jul 4, 2010
    Location:
    Appleland, USA
    #2
    Take it to an Apple Store and tell them what happened. I would NOT even attempt to open it up and try to fix it myself.
     
  3. srf4real macrumors 68030

    srf4real

    Joined:
    Jul 25, 2006
    Location:
    paradise beach FL
    #3
    Oh, dear. Those electronic components were never meant to be sumberged in water. I am with above poster- taking it apart to do exactly what? You need Apple tech to look at it for you, before you have done irreversible damage.
     
  4. Katie785 thread starter macrumors newbie

    Joined:
    Dec 30, 2011
    #4
    it's out of warranty, and i got AT&T before they offered any protection. The only thing they're going to do is laugh at my stupidity for dropping it.


    update: I can put it in restore mode while plugged into iTunes, then iTunes sees it. When trying to restore it, I get error code 2001 "unknown error" and please do not post if you do not know what you're talking about technically. There are hundreds of iPhone breakdowns explaining how to clean a water damaged phone. I wasnt sure if anyone had experience with avoiding opening it up if its just a software/firmware issue.

    I also tried restoring with ios 5.0 firmware and the original 4.2.0 or whatevr. the 5.0 says it's not for that model. The 4.2.0 attempts to do it, but then says it's not a match.

    http://www.youtube.com/watch?v=UqyLiNObPM8&feature=related
     
  5. lordofthereef macrumors G5

    lordofthereef

    Joined:
    Nov 29, 2011
    Location:
    Boston, MA
    #5
    They may not. They have replaced out of warranty phones more than once in this way, sometimes for free even. I ran mine through the wash the night it launched. They replaced it for $100. While $100 hurt, it was better than their standard $200 policy.
     
  6. DocNYz macrumors 6502a

    DocNYz

    Joined:
    Jun 9, 2008
    Location:
    East Coast, USA
    #6
    I have almost the exact same problem with a 4, it only turns on when plugged into the wall with an older cable and when trying to restore in DFU mode, I get the 2001 error, and a couple times the 2006 one. Also out of warranty. Have you had any luck? Did you try replacing the battery?
     

Share This Page