Resolved iPhoto/imovie/Garage band missing from MBP after Genius Bar trip.

Discussion in 'MacBook Pro' started by ChrisTX, Jul 4, 2011.

  1. ChrisTX, Jul 4, 2011
    Last edited: Jul 4, 2011

    ChrisTX macrumors 68030

    ChrisTX

    Joined:
    Dec 30, 2009
    Location:
    Texas
    #1
    So I had problems with 10.6.8 which left my MacBook Pro unusable. So after searching online, and these forums, my only option was to take it in to the Genius Bar for their assistance. Since I did not have a backup in time machine, I ended up purchasing an external HD and let them see if any of my data(pre crash) could be recovered, and let them back up my data to time machine. Well when my Macbook Pro was ready I picked it up and at first glance looked as if all of my music had been recovered, as well as some other personal data. However once I got home with it, I noticed iMovie, iPhoto, and Garage band were missing from the dock, as well as MS Office. In it's place I get the grey question marks instead. Is this normal, or are these backed up on the external drive somewhere? I'm not entirely too worried about MS Office, but A little worried about the other 3 programs that are missing here. I will be away on vacation for a week, but should I return to the Apple store with this problem, or is this a normal/easy fix? Any help would be appreciated.
     
  2. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #2
    It sounds like they need to be reinstalled. The easiest thing to do is to pop-in the Application Install disc (disc #2) that came with your Mac. It's the same story with Office. The question marks indicate that there are invalid application icons in your dock; just drag them off since they'll be recreated when you reinstall iLife and Office.
     
  3. ChrisTX thread starter macrumors 68030

    ChrisTX

    Joined:
    Dec 30, 2009
    Location:
    Texas
    #3
    Thanks, that's what I figured, just wanted to make sure they were recoverable!
     
  4. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #4
    I should add that you should check the Applications folder first to make sure they really are missing since the problem could be isolated to the dock icons. If the programs are indeed missing it's as simple as reinstalling them.
     
  5. ChrisTX thread starter macrumors 68030

    ChrisTX

    Joined:
    Dec 30, 2009
    Location:
    Texas
    #5
    Yeah, they're definitely missing. The first thing I did was check the applications folder. Then I did a basic search for them, and nothing. Reinstalling them now. Thanks for the advice.
     

Share This Page