iPhoto won't load, generic icon

Discussion in 'Mac Apps and Mac App Store' started by 5300cs, Apr 5, 2004.

  1. 5300cs macrumors 68000


    Nov 24, 2002
    On top of a suddenly generic icon for iPhoto, it will not load. I ran Console in the background and it gave me this:

    2004-04-06 13:41:52.417 iPhoto[533] Unable to load nib file: MainMenu, exiting

    What on earth is this? Tried trashing it and reinstalling -twice- but it didn't work.

    Anyone, any ideas?? :confused:
  2. MacRAND macrumors 6502a


    May 24, 2003
    Phoenix AZ USA
    Permissions problem?

    Your Profile lacks any information about your computer(s), nor have you shared your computer & system setup in your post.
    Updating your Profile would help us help you.
    By the way, happy birthday (mine was the last day of March).

    1. Have you run disk permissions on your OS X drive using the Apple Disk Utility in the Utilities folder within Applications?
    If you are not being allowed to trash iPhoto, it sounds like permissions for the program have become confused, corrupted, thereby denying you Authority to trash it.
    Backup your iPhoto files inside your User's Pictures folder before you do anything, however, they should be tucked safely where they are - in your User's Documents folder, away from the Application itself.

    2. Do you have a source for iPhoto to reload, like an iLife disc?
    If so, have you tried simply re-installing new OVER the old version?

    3. Instead of using the Terminal (I'm totally lacking in core language control), if you have OS 9.2.2 (not just Classic) you can startup in 9, then go to your copy of iPhoto that you have been denied permission to Trash on the main Macintosh HD drive, and trash the file in 9 followed by EMPTY TRASH. It should no longer be on your OS X disk.
    4. Select OS X as your Startup drive (again) through the Apple Menu Control Panel, RESTART in X and check to see if iPhoto is gone.

    5. If iPhoto is gone from the Applications folder, install a fresh version of iPhoto and pray for a fix.

    6. Another thing you can do is go into your System's Preferences folder and try trashing all the iPhoto related preference files, which may have become corrupted.

    Hopefully, someone else who knows about OS X structure and the "nib" file can help you out with that; I don't know.

    Where in Japan are you? My favorite city is Sasebo, and I loved visiting Arita, especially touring the chinaware factories (Kaikiemon) which are world famous as Aritaware, and points in between.

    Attached Files:

  3. HexMonkey Administrator


    Staff Member

    Feb 5, 2004
    New Zealand
    I'm no expert, but nib files are basically just interface files. MainMenu.nib is a file that contains information about iPhoto's menubar. If you control click on iPhoto and select Show Package Contents, then you should be able to find this file at iPhoto/Contents/Resources/English.|proj/MainMenu.nib.
  4. 5300cs thread starter macrumors 68000


    Nov 24, 2002
    I'm sorry, I should've given more system infomation.
    It's a 550TiBook running 10.3.3, 512Ram.
    I know I'm going to sound like a windoze user, but "it just stopped working, I dunno what happened." I really can't add more than that in terms of how it happened.
    What I did was delete the actual application then try and reinstall. This worked, but then when I launched iPhoto again, it would load up, try reading my iPhoto Library then crash. I renamed my iPhoto Library to something else and now iPhoto loads, but the generic icon remains.

    Eh, I'm just going to reformat. I was going to anyway. I appreciate everyones input, they have helped a lot, even if it doesn't seem that way.

    I live in Nagoya, by the way. Not really a nice city...
  5. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    The icon problem can be fixed by rebuilding the Classic desktop file (this can be done whether or not the Classic environment is present). You'll need to log out and back in for the change to take effect.

Share This Page