Ipod Classic 6th Gen Replaced HDD & Circuit Board But Ipod Still Not Working

Discussion in 'iPod' started by Jambox, Nov 2, 2010.

  1. Jambox macrumors newbie

    Nov 2, 2010
    Ok so this is kind of long but i realy need advice. My freinds ipod classic (6th Gen) stoped working about two month ago and displayed that red x when its turned on. He orderd a new hardrive and circuit board becuse he thought that to be the problem but after replacement the same problem occured. He gave up on it and sold it to me for $20, now im not an expert at electrical device repair but i figured i would give it a shot seince he had orderd the parts. I watched several videos online on how to replace the hardrive and circute board and the one thing i realized was that he had connected the hardrive cable bacwards so after fixing that problem (I connected the old drive seince it had all his music in it) i started the pod but got the same red x. I checked all the connections to make sure they were on tight and noticed the battery cable to be the only one that had some play to it, as I moved the cable the pod would turn on then off. After trying diffrent angles with the cable for once the ipod loaded and it was working well untill i moved it a bit and it turned off. I still had it open and i knew that if i left the cable like that it would just be turning the pod on and off with any movement. So I unpluged the battery and inspected the cable it seemed to be bent and broken close to the tip were it conects to the circuit board. I orderd a new battery (just got it today) installed it and tried the ipod but no luck. And now im out of ideas and would apreciate any suggestions. Should i just bury this one and get another is it done for good? :confused:

Share This Page