iPod not recognized/won't mount in OS X. Reformat?

Discussion in 'Mac Help/Tips' started by moose, Mar 25, 2003.

  1. moose macrumors newbie

    Mar 5, 2003
    For some reason my iPod has recently taken to not mounting under OS X. In classic it comes up sans problem. I have tried it on an iBook, and on my G4, both to no avail. I have re-installed the 1.2.1 updater but that doesn't seem to have worked either.

    Other than the (critical) mount issue, the iPod seems to be working without any problems. I can listen to music that is already on there fine, and all of the menus are in proper working order. But none of this does me any good if I cannot drag new music to it.

    So here's my question: Can I re-initialize the drive when the OS X drive utility prompt comes up without losing the software that makes the iPod... an iPod? Is that information resident in firmware, or will I have a mute hard drive after initialization?

    Booting into Classic just to use the iPod is not an option, btw. I want it to work correctly. Help! :(
  2. Chad4Mac macrumors 6502

    Apr 20, 2002
    Los Angeles
    Here is the link to a Apple Knowledge Base article that explains how to fix your "sick" iPod.

    This should do the trick

  3. moose thread starter macrumors newbie

    Mar 5, 2003
  4. Ajmbc macrumors regular

    Jan 29, 2003
    This happened to one of my friends. If you are using any software to get music off of your pod, then this might be it. So give this a shot:

    Since you can listen to music, then it is not the issue discussed in that info document.

    1) Try putting it into forced firewire mode.
    Connect it to the computer
    and reset your iPod by holding down the menu and play buttons simultaneously.
    When the apple logo appears, hold down the back and the next buttons until it says "Do not disconnect"

    If your iPod does not appear in iTunes or on the desktop, then you need to reformat.

    2) If you have important software on the iPod, repeat step one and do this : Go>Go to folder>
    and type in /volumes

    3) a folder should appear with all of the volumes connected to the computer.

    4) open the iPod and get the stuff off.

    5) open the iPod updater and click restore !warning!- your music will be erased.

    6) Follow the directions on the screen.

    Hope this helps!!!
  5. Ajmbc macrumors regular

    Jan 29, 2003
    That applecare doc gives the correct instructions, not the correct diagnosis. Go to /volumes if you want your data. :eek: SORRY AGAIN!

  6. moose thread starter macrumors newbie

    Mar 5, 2003
    OK, I didn't read the directions correctly, and didn't hold down the back and next buttons simultaneously, after the apple icon appears. I'll try that again tonight. Not that it matters now as the iPod is empty.

    Unfortunately, the issue still persists...

    Here's another oddity that may help or confuse the matter:
    The iPod now appears on the desktop sans issues. However, as stated, it still isn't appearing in iTunes, and the "Update iPod..." action is greyed out in the drop down menu... in OS X.

    I rebooted into OS 9.2.1 and ran iTunes 2, and a warning window came up saying that the software used to communicate with the iPod was not installed correctly and that I should: 1) dismount the iPod before each launch of iTunes, and 2) I should re-install iTunes. What followed was the iTunes window for me to set up my iPod for iTunes connectivity.

    "Ah-ha!", thought I. This is what I wanted to happen under OS X. Perhaps this was the same issue that was thwarting iTunes 3.0.1 under X, but I just wasn't getting the warning window. Armed with that information, and a renewed sense of optimism, I backed up my prefs for iTunes 3.0.1, deleted the receipt file, the prefs, the dock icon, and the app itself, and re-installed from scratch. Nothing. I then went into a corner and cried myself to sleep.

    So, my question is: is it possible that this is an iTunes issue, as the OS 9 version of iTunes seemed to indicate? If so, how can I get 3.0.1 to play ball? Is the iPod setup assistant buried somewhere in the system folder? What more can I do besides reinstalling iTunes ad nauseum?

    Thanks again for all you guys help thus far. And my apologies for my long winded explanations. It is so frustrating to have such a great product that I had come to depend on for all my mobile music needs sitting on my desk like a pricey paperweight.
  7. King Cobra macrumors 603

    Mar 2, 2002
    First off, moose, why are you running version 1.2.1 of your iPod's software? You should have the latest software, 1.2.6, first, as well as the latest OS X and iTunes software. (If Mac X 10.2.4 is causing critical problems with your system, and you are using 10.2.3, let's navigate from there, as well.)

    Second, if all the songs you have access to are on your computer, and you have your music/data on your iPod already stored elsewhere, I suggest a full restore. If you don't already have the software 1.2.6 for OS X, download first from the Apple website. Then restore. You will lose all of your data and your iPod's settings will be reset.

    If restoring the iPod is equally not an option, try simply updating your iPod software to 1.2.6 instead of restoring the iPod. You will keep your music/data.

    If this still does not work, your iPod is not recognized by the update software, and none of the suggestions here aid you, post your question at TheTechPub.com and provide all of the information you have listed, as well as what you have tried (registration required, first).
  8. moose thread starter macrumors newbie

    Mar 5, 2003
    I have latest everything: 3.0.1, 1.2.6, and 10.2.4. The problem didn't occur after an install of any of the above.

    Already done. Didn't work. Now I have an empty iPod that is not recognized by iTunes.

    Done. See above.

    iPod was successfully updated, restored, etc. and now appears on the desktop. The remaining issue is with iTunes which doesn't register the iPod in the Source list. Thus my question regarding iTunes. I re-installed 3.0.1 but to no avail.

    Thanks for the other site info, I will try them too...
  9. coolbreeze macrumors 68000


    Jan 20, 2003

    Looks like you and I are screwed. I've tried everything. Deleted my iPod, reformatted, etc. Nothing.

    I feel like a victim here, and I did nothing to warrant it. Hm. Welcome to Macintosh. Jeez...
  10. moose thread starter macrumors newbie

    Mar 5, 2003
    There is hope yet, although it will require Hurculean efforts, and much fear. I fixed mine finally, after 4 hours of fiddling.

    First off, forget Disk Repair on the iPod. It won't get you anywhere, other than running in circles. My opinion, rooted in superstition and supposition, is that it is not just an iPod issue. Also, I opened the iTunes preference files, and saw that the XML code was referencing very old data, such as an external drive that has not been there for at least 6 months, and a myriad of other oddities. So I think it might be software on the Mac that also becomes corrupted. Here's what I did:

    1. With iPod plugged into power outlet (not computer), I reset it by holding down the Menu and Play button simultaneously. When the Apple icon pops up, immediately hold down the forward and reverse buttons simultaneously. It might make a little clicking sound. Now plug the iPod into a firewire port on the computer and see if that works.

    2. If that didn't work, unplug the iPod and run a diagnostic to see if the iPod itself is damaged internally, or corrupted. Diagnostic instructions here: http://www.ipoding.com/modules.php?op=modload&name=Sections&file=index&req=viewarticle&artid=3

    If, at any point during a diagnostic run, you find that it is looping, or taking an inordinate amount of time, just got back to step one, and reset. That will pop you back into regular iPoding mode (hopefully).

    3. Plug the iPod back in again.

    4. If it comes up on the desktop, rejoice, you are a third of the way there! The real test is if iTunes launches. If it does, and asks you to configure the iPod, you are set. If it doesn't, launch the latest iPod Updater (1.2.6, as of this writing, and located in your Applications > Utilities folder). Back up any data you have on the iPod that is precious to you. Run the Restore function when the option appears. This will wipe all data from your hard drive!

    5. Delete iTunes completely. Pref files, receipt files, dock icon, and the app itself.

    6. Shut down computer. Unplug all Firewire devices. Leave off for 15 minutes. This supposedly resets the Firewire bus on the Mac, in case that is an issue.

    7. Start up the Mac, and zap the PRAM (Option + Open Apple + P +R)

    8. Plug the iPod back in. See if it works... For some people this is the last step. For me, it still wasn't working. If that is the case for you too, continue reading...

    9. Put the OS X Disc 1 Install CD in. Choose it as your start up disk and restart.

    10. Run Repair Disk on your Mac. Verify and Repair Permissions. (Might take a little while).

    11. Restart, and hold down the option key. When the window pops up, click on your OS X disk, and then click on the right arrow. Why Apple made that so user-unfriendly is beyond me. (There is another option, if you want, which is when you hear the restart chime, hit the eject button on your CD, and snatch the OS X install disk out of the tray... this is actually my preferred option since the other one takes forever).

    12. Re-install iTunes 3.0.1. Restart again.

    13. Plug in iPod. Slaughter sacrificial lamb. (Please note, that this is step 13... that was not intentional)

    Hopefully somewhere along the line, you were able to make it through alive, and the iPod is now back in top form.

    Along the way, I formed a loose patchwork of solutions from a variety of sources, some of which you may want to check out if none of the above works:







Share This Page