iPod Touch 2G MB - 3.0 to 3.1.3? Please advise a slightly confused newbie

Discussion in 'iPod touch Hacks' started by kitkat2, Aug 29, 2010.

  1. kitkat2 macrumors member

    Joined:
    Aug 29, 2010
    #1
    I have an iPod Touch 2G, non MC version. I'm currently very happily running 3.0, but I want to use the new Netflix app, which requires 3.1.3. This iPod has never been jailbroken.

    Is it possible to upgrade to 3.1.3 or even 4.0.x and retain the possibility to go back to 3.0 if I decide I really don't like it?

    If yes, how would one go about it?

    I've been reading through this sub-forum and have already learned a few things, but I'm new to hacking my iPod so there is a lot of terminology that I'm still unfamiliar with. I have no problem looking stuff up, but at this point I'm not yet sure what to look for. If anyone can help point me in the right direction I'd very much appreciate it. Thanks!
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    You can't upgrade to iOS 3.1.3, but you can upgrade to iOS 4.0.2.

    To be able to downgrade back to iOS 3 if you don't like iOS 4, you have to jailbreak your device before you upgrade and save your SHSH blobs using TinyUmbrella (free app).
     
  3. 0dev macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #3
    If you're already jaibroken and you've stored your SHSH blobs in Cydia, you can always point to Saurik's server to downgrade later if you want.
     
  4. kitkat2 thread starter macrumors member

    Joined:
    Aug 29, 2010
    #4
    Thanks!
    I have not jailbroken, but it sounds like I need to before upgrading if I want the possibility to go back. This is one of the things I was trying to figure out.
     
  5. gixxerfool macrumors 6502a

    gixxerfool

    Joined:
    Jun 7, 2008
    #5
    As far as I'm aware since apple no longer signs for anything but 4.0.2 even tryin to save your blobs now is pointless. If you try to save your blobs now it will only save them for 4.0.2.

    I'm not familiar with an MB model but I think you can Downgrade at will as long as it's below 4.0. For 4.0 and above you will need blobs to move go a specific version.
     

Share This Page