iPod Touch 2nd Gen 8gb not Syncing/Charging, showing up in iTunes 9 or my Mac

Discussion in 'iPod touch' started by Wastedd, Oct 3, 2010.

  1. Wastedd macrumors newbie

    Oct 3, 2010

    I have a jailbroken 8gb 2nd Gen iPod touch on OS 4.0, that i bought in July.
    I have a Mac OS X 10.4.11 computer, with iTunes 9.2
    My iPod is not showing up in iTunes or my HD directory, nor charging. It charges perfectly fine when plugged into my wall plug, and the USB plug is not broken, as it works perfectly with my iPod Nano.

    I don't think it has anything to do with the fact that I've jailbroken it, considering the fact that I jailbroke it one week after I got it, and it has been working perfectly ever since. It was working when plugged into my computer 2 days ago, but it is refusing to even charge when connected now - and I haven't updated anything with Cydia or Installous since before the last time I plugged it in to my computer.

    What is wrong? What can I do to fix it? I've tried restarting my computer, soft resetting my iPod, and trying all of the 6 USB ports I have. This is becoming frustrating and I really don't want to have to reset my iPod completely, as there are notes and calendar dates that I would rather not lose.

    Any suggestions? I am literally at a loss. - Thank you for your time!
  2. Wastedd thread starter macrumors newbie

    Oct 3, 2010
    I fixed it! :D All I had to do is reinstall iTunes. Sorry for taking up thread space... You can delete it if you want to, but I think it might be helpful to the many people I've seen online complaining about the same problem. :D

Share This Page