Irritated. Please help.

Discussion in 'iPhone' started by DataEast, Mar 8, 2012.

  1. DataEast macrumors member

    Joined:
    Sep 13, 2011
    #1
    My dad just switched us from Sprint to Verizon and he got an iPhone 4s and I just swapped my Sprint unit 4s to a Verizon. I restored to the last back up and everything is fine except my contacts. For some reason a lot of them are just numbers. When I edit them to add their name it still just displays their number in the message app. Why and how can I get their names to display instead of numbers.
     
  2. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #2
    Are the numbers correct? And make sure they are just 10 digit numbers. My mom had my number wrong in her contacts and all my messages to her showed up as my phone number. I would also delete the prior conversations.
     
  3. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #3
    I had this problem when I roamed internationally with my Verizon iPhone 4s, and then came back to the US.

    Dialing *228 and doing option 1 fixed it for me. Make sure your Verizon SIM card is in there when you do that.
     
  4. DataEast thread starter macrumors member

    Joined:
    Sep 13, 2011
    #4
    Fixed it. All I had to do was add + 1 and then the number. I don't know why that's so important now but whatever. Thanks though.
     
  5. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #5
    Exactly the opposite of what I said. Sorry about that. :( Definitely time for bed.
     

Share This Page