Is 10.6.5 update safe for those of us with flashed graphics cards?

Discussion in 'Mac Pro' started by jshbckr, Nov 10, 2010.

  1. jshbckr macrumors 6502

    Joined:
    Apr 20, 2007
    Location:
    Minneapolis, MN
    #1
    Last time I updated to 10.6.4, my computer went on the fritz and I couldn't get an image with my flashed 4870.

    Anyone know if there is something I need to do special when I update? Will I have this issue if I go to 10.6.5?
     
  2. Transporteur macrumors 68030

    Joined:
    Nov 30, 2008
    Location:
    UK
    #2
    Just create a clone from your current system (for example with CCC) and if the update breaks your machine, simply restore your system.
     
  3. Ikyo macrumors 6502

    Ikyo

    Joined:
    Feb 27, 2008
    #3
    I would wait until they have a patch for it. The most recent is 10.6.4 + Graphics Update
     
  4. idr2020, Nov 10, 2010
    Last edited: Nov 11, 2010

    idr2020 macrumors newbie

    Joined:
    Jun 28, 2010
    #4
    10.6.5 update breaks QE on flashed 4870. It defaults to apple software renderer.
     
  5. ammon macrumors regular

    Joined:
    Sep 24, 2005
    Location:
    Colorado
    #5
    I tried it with my flashed 4870, and it isn't working. (no QE, CI, etc)

    I also tried switching back to the 10.6.3 drivers, like I did with 10.6.4, but now it won't boot at all! It goes through boot, then keeps flashing between two shades of blue, but never makes it to the login window.

    Luckily I still have my 1900XT I can put back in and try to fix it.
     
  6. neckarb macrumors regular

    Joined:
    Jun 29, 2007
    #6
    I just updated with my flashed 5870, works fine. :)
     
  7. Atomic101 macrumors member

    Joined:
    Jul 19, 2010
    Location:
    Nottingham
    #7
    Also went without a hitch on my Pro 3.1 & sapphire 5870 -cant say it has improved my cinebench scores though

    andy
     
  8. Ikyo macrumors 6502

    Ikyo

    Joined:
    Feb 27, 2008
    #8
    Most of the 5770 and 5870's will work because they already have support in the OS.
     
  9. ammon macrumors regular

    Joined:
    Sep 24, 2005
    Location:
    Colorado
    #9
    The OS supports the 4870s too. (Apple still sells a retail 4870 for the Mac Pro) However, the kexts in 10.6.4 and 10.6.5 have added something that detects flashed 4870s and then disables them. In 10.6.4 all that was needed was to revert back to the kexts from 10.6.3. But those kexts no longer work with 10.6.5.
     
  10. gpzjock macrumors 6502a

    Joined:
    May 4, 2009
    #10
    OpenGL 2.1 working as intended

    Installed 10.6.5 update last night, WoW runs on all settings now but with no significant improvement in fps.
    Sapphire HD5870 Vapor-X in a Mac Pro 3,1 2.8 ghz (2008).
     
  11. yuser macrumors member

    Joined:
    Sep 18, 2009
    #11
    4890 working

    Hello,

    just to confirm it... Mac Pro 1,1 with flashed 4890 and the released qe-ci patch from netkas is working.
     
  12. bpd115 macrumors 6502a

    bpd115

    Joined:
    Feb 4, 2003
    Location:
    Pennsylvania
    #12
    I have a flashed XFX Radeon 4870 and have never had an issue with a software update.

    I updated last night to 10.6.5 and played Left4Dead 2 at 2560x1600 4xaa with no problems.
     
  13. marshaul macrumors newbie

    Joined:
    Oct 10, 2010
    #13
    I wish I was so lucky. My experience is the same as two previous posters in this thread.

    10.6.5 update broke QE/CI for my flashed XFX 4870 1GB.

    Does anybody have any idea if the QE/CI patch netkas just released will help those of us with 4870s that are no longer working in 10.6.5?

    http://netkas.org/?p=564
     
  14. Gomff macrumors 6502a

    Joined:
    Sep 17, 2009
    #14
    I could be completely wrong about this but since none of the usual ROM experts seem to be available for comment at the moment, I'll chip in.

    I believe that the nearer to reference design your card is, the more likely it will work OK with the OS X update. If you have such a card, chances are you didn't have to do any tweaking to the ROM before flashing it. In which case I believe you should be OK although it's best to try it out on a test install or clone your system first, just in case.

    I bought a 4870-ZDFC reference card just as they were starting to be scarce. I'm currently downloading the 10.6.5 update and will try it on a test OS X install to see if all is well. I'll report back....I'm hopeful it should be fine though.
     
  15. chych macrumors member

    Joined:
    Apr 28, 2010
    #15
    No problems on a Powercolor 4870. Never had to do any hacks to get it 100% working in OS X, other than the initial flash.
     
  16. Gomff macrumors 6502a

    Joined:
    Sep 17, 2009
    #16
    Just installed the 10.6.5 update on my machine and all seems to be working well. All the OpenGL screensavers work super smoothly, there's a shadow on my mouse cursor, and I loaded up a heavy 3D graphics scene which seemed just as agile in the viewport as it always has been so I'm assuming everything is OK.

    I don't have Steam installed on my test OS X install but once I've updated my main installation I'll test Portal on it.....I'm pretty sure it should be fine though.

    I'm pretty sure that if you have a reference card, there shouldn't be issues but if you had to do some ROM editing / hacking to get your card to work initially, then you may have issues that require the help of netkas / Rominator (on netkas's forums) or Cindori.

    Hope this helps.
     
  17. coochiekuta macrumors 6502

    Joined:
    Nov 6, 2010
    Location:
    here and there
    #17

    is this true or propaganda? im not calling you a liar but would they really be so low as to actively place roadblocks upon people who want to use a video card of their own choice? that does not sound like customer friendly service. :confused:
     
  18. Yorb macrumors newbie

    Yorb

    Joined:
    Nov 13, 2009
    Location:
    Raleigh, NC
    #18
    Just thought I'd chime in that I updated to 10.6.5 and, as expected, it broke my QE_CI. I have a 4890 (Sapphire New Edition w/ Hynix memory). Tried running netkas's update, didn't work. Found out it didn't actually overwrite the extensions (his installer has NEVER EVER worked for me), so I manually deleted the extensions and then it worked. Still no QE_CI though, so I tried the mapp.zip extensions that have worked for me in the past, and that caused my computer to HANG on blue screen, flickering back and forth between darker blue and lighter blue every few seconds (trying to load graphics drivers I'm assuming). Had to safe boot, trying Combo update and then netkas's patch again... I'll keep you posted. :(
     
  19. BKNY macrumors member

    Joined:
    Jun 21, 2010
    Location:
    Earth
    #19
    Hey

    not rushing into the update. i always wait at least 2 weeks to make sure no problems then i do the update.
     
  20. ammon macrumors regular

    Joined:
    Sep 24, 2005
    Location:
    Colorado
    #20
    I totally hear what you are saying. I don't think Apple did it to prevent people from flashing a PC card for using in a Mac, but rather from people building a Hackintosh with a PC 4870. Unfortunately those measures effect us.
     
  21. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #21
    bpd115 - do you happen to know exact model number of your card? is it by any chance VGA XFX HD-487A-ZDFC 4870?
     
  22. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #22
    Gomff - is your card XFX HD-487A-ZDFC ?
     
  23. Gomff macrumors 6502a

    Joined:
    Sep 17, 2009
    #23
    Yep, that's the one. Seems to work fine under 10.6.5 but like I said, I think this is because it's a reference design, hence very similar indeed to the Mac versions except for the 2nd DVI socket instead of MDP.
     
  24. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #24
    Thats very good news for me as I have identical model. I guess I'll be updating tonight after i do cloning via CCC.

    I guess it was a good idea to get this specific model :)
     
  25. Gomff macrumors 6502a

    Joined:
    Sep 17, 2009
    #25
    It would be great for you to post your results back here just to make the picture clearer for everyone else.
     

Share This Page