iPhone Is it possibe to upgrade and re-jailbreak (in order to unlock) a 3Gs running on 4.1?

Discussion in 'Jailbreaks and iOS Hacks' started by amstrad, May 10, 2013.

  1. amstrad macrumors member

    Joined:
    Aug 6, 2009
    #1
    Hello,

    I have a locked 3Gs running 4.1 and it's pretty annoying to not be able to install anything on it anymore (most apps nowadays require at least 4.3)

    So i would like to know if it will be possible to jailbreak it (to be able to unlock it) after upgrading it, or should i just leave it at 4.1 and use the basic functions ?

    Modem firmware : 06.15.00

    Thanks
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Do you have any SHSH saved ?

    Also, you should get rid of iPad baseband.
     
  3. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #3
    Open cydia and click TSS center. What iOS version SHSH blobs do you have?
     
  4. amstrad thread starter macrumors member

    Joined:
    Aug 6, 2009
    #4
    Hello,

    Thank you guys for your answers.

    These are the SHSH versions that show up in cydia :
    Code:
    3.1.2, 3.1.3, 4.0, 4.0.1, 4.1, 4.2.1r1, 4.3.5, 5.0.1, 5.1.1, 6.1.3
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    So, after you remove the iPad baseband, you have choice of jailbreak on 6.1.3 either tethered (new bootrom) or untethered (old bootrom) or 5.1.1 guaranteed untethered.

    You can software unlock either way
     
  6. amstrad thread starter macrumors member

    Joined:
    Aug 6, 2009
    #6
    Ok, thanks

    Any guidelines on removing the ipad baseband ?

    Is there something else i need to check before ?
    Having a locked device running on 5.x or 6.x would be worse than what i have now :)
     
  7. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #7
    Use redsn0w to downgrade the baseband. dhlizard recommends the 0.9.14b2 version (I believe)
     

Share This Page