Is it safe to update apps for 4.2 on phone w/ 4.1 j/b?

Discussion in 'Jailbreaks and iOS Hacks' started by MrThompsonR, Nov 11, 2010.

  1. MrThompsonR macrumors 6502

    MrThompsonR

    Joined:
    Dec 15, 2009
    #1
    Is it safe or should I disregard these until I upgrade to/ jailbreak 4.2? I remember after updating some apps on my old 3G(j/b 3.12) to 3.13 my phone started crashing alot and after a few reboots wouldn't come back up fully, forcing me to restore/ update to Apples latest iPhone software/ killing my jailbreak...? Could this happen again? I'd rather stay away from iTunes for awhile than go through that again... From what I've read 4.2 doesn't sound like a great leap from 4.1 on an iP4... Opinions? I usually sync daily for podcast for my commute to work. Even w/o phone software, there's reminders for app updates...
     
  2. BeijingiPhone macrumors newbie

    Joined:
    Nov 13, 2010
    #2
    4.2 contains a new baseband and there's no unlock available yet
     
  3. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #3
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    I believe the OP is asking if it's ok to install iTunes apps that are updated to 4.2 compatibility. If that is the question I say you are fine as long as the app doesn't come with a built-in version requirement.
     
  4. famoussasjohn macrumors 6502a

    famoussasjohn

    Joined:
    Jul 7, 2010
    #4
    should be fine. one of my apps had an update for 4.2 compatibility, and it worked fine after I installed it.
     
  5. Badfoot macrumors 6502

    Joined:
    Sep 27, 2009
    Location:
    London, UK
    #5
    I believe if it does it will flag it up, and probably won't let you download it until the update is done.
     
  6. MrThompsonR thread starter macrumors 6502

    MrThompsonR

    Joined:
    Dec 15, 2009
  7. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #7
    TS, the only way to know is this: If the app states that REQUIRES 4.2 & up then you can't run it w/ fw less than that version; most apps say COMPATIBLE to 4.2 which means that they work w/ lesser fw versions (up to a certain point depending on the app, which they usually also stipulate on the info).:cool:
     

Share This Page