Is my SIP completely disabled? - And why do I have to partly enable it for XtraFinder then?

Discussion in 'OS X El Capitan (10.11)' started by Erdbeertorte, May 18, 2016.

  1. Erdbeertorte, May 18, 2016
    Last edited: May 18, 2016

    Erdbeertorte macrumors demi-goddess

    Erdbeertorte

    Joined:
    May 20, 2015
    Location:
    Castle Grayskull, Eternia
    #1
    Hi,

    when XtraFinder is launching I always get a message that SIP is enabled.

    But I disabled it with "csrutil disable" from the recovery partition and the status says just "System Integrity Protection status: disabled" when I write "csrutil status" in the Terminal.

    In some of the earlier beta versions of El Capitan it showed something similar as in the first screenshot but all listed options were disabled. I can't remember if those were the same options but I think it had been only five and not six.

    Maybe it's that debugging restriction that has to be disabled in addition but I don't know how to do it.

    XtraFinder seems to work normally in both cases just that message is annoying. But I am not 100% sure if really everything works like it should because I never used it before.

    The XtraFinder website says in its workaround only a part of SIP has to be disabled with "csrutil enable --without debug".

    The status looks like that if I do it and I don't get the message anymore:

    Screen Shot 2016-05-18 at 12.48.51.png
    Could it be that there is any option what is disabled by that command but not when I think it is completely disabled or is it just a bug of XtraFinder what looks only for that special configuration? The support of XtraFinder did not answer me. :( I wrote an email already some weeks ago.

    I did not find any other commands to disable options in addition to the "completely" disabled SIP. Or how the "without" command for the other options could be. When I type "csrutil help" it just shows this:

    Screen Shot 2016-05-18 at 13.28.12.png
    I already tried things like "csrutil disable --with(out) debug". I think it did not recognize anything behind the disable command because it always happened the same as with just "csrutil disable". So like I already wrote I need some command like "csrutil enable --without everything". ;)

    Does anyone here maybe know if there is a way to do that or if it's just an incorrect message from XtraFinder?

    I would be happy for any help. :)
     
  2. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    That's probably it, if I remember correctly the XtraFinder message started showing up in 10.11.2. Something with how it detects if SIP is enabled, but after dismissing the message it works just fine. I've been waiting since then for a fix to stop it from popping up after every login, but XtraFinder hasn't received any updates yet.
     
  3. slvrscoobie macrumors 6502a

    slvrscoobie

    Joined:
    Mar 24, 2013
    Location:
    NJ
    #3
    yeah I used Xtrafinder for a long time to use folders on top. However, support for it seems to have died out. No updates since last year on the FB page : https://www.facebook.com/XtraFinder/
     
  4. Erdbeertorte thread starter macrumors demi-goddess

    Erdbeertorte

    Joined:
    May 20, 2015
    Location:
    Castle Grayskull, Eternia
    #4
    @redheeler and @slvrscoobie

    Thank you for your answers. So it seems to be like I thought. XtraFinder does not detect the configuration from its workaround and thinks SIP is not disabled even if it is completely.

    Did you notice any problems using it? I just tried it a few times for a while and it seemed to work with both settings and I just ignored the message. But it behaved a little strange sometimes when resizing the columns. I don't no why I exactly uninstalled it. Maybe it was just the annoying message and I need SIP disabled completely.

    Sad that it probably won't be updated anymore if there are no big problems with disabled SIP or just two of that six configuration options. :(

    I got Commander One PRO with a bundle and will try that one. But it's a totally separated app and not integrated in the Finder. Reminds me of the old muCommander, what still works but I think just with that special Java 6 version from Apple and looks almost like Norton Commander for DOS. :)

    The latest version is only two weeks old. I'll just try if it might be helpful for me. I Just launched it for the first time.

    I really don't like the Finder, especially that the folders are only on top if you sort by file type and I never found any way that it permanently shows folder sizes and sorting options everywhere. It seems it always forgets my settings and they are never systemwide.
     

Share This Page