is there a way to disable to keyboard and mousepad to use external ones?

Discussion in 'MacBook Pro' started by supermarky, Feb 18, 2012.

  1. supermarky macrumors newbie

    Joined:
    Sep 16, 2011
    #1
    my mousepad is so screwed up... that whenever I drag everything gets selected and in order to click I have to bash the thing. I guess this cause drops of sweat fell on it.

    the keyboard is usually next to impossible to use because of this problem with the pad... as it is impossible to avoid transient contact with it which wouldn't register if it were working properly but which causes lots of consternation...

    I've tried simply plugging a keyboard and mouse into the usb ports but this isn't working out. the keyboard doesn't seem to be recognized at all. and the mouse... behaves very strangely: often I can't do any clicking at all (sometimes I can), often I can't drag the mouse without its selecting everything in its path (sometimes I can).

    I'm almost unable to use the computer at all at this point.

    PLEASE TELL ME THERE'S A WAY TO DISABLE THE MOUSEPAD AND KEYBOARD! this is driving me completely nuts.

    thanks
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    If your external keyboard isn't recognized, the last thing you want to do is to disable the internal one. Then you wouldn't be able to communicate at all with your Mac. First you need to make sure your external is working properly.
    • Try a different USB port.
    • Inspect the connectors and ports to make sure they're clean and undamaged.
    • Make sure the connection is secure.
    • Try the keyboard with another computer, to make sure it's working properly.
     
  3. supermarky thread starter macrumors newbie

    Joined:
    Sep 16, 2011
    #3
    I already assumed the keyboards and mice I've tried were no good.

    Just now trying it with brand new ones, and it doesn't matter which usb port I use and the connection was ... as secure as it can be plugged in to the hilt.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Did you try it again after restarting your computer? You really need to focus on getting an external keyboard to working before you even consider disabling the internal one.
     
  5. supermarky thread starter macrumors newbie

    Joined:
    Sep 16, 2011
    #5
    Hey that worked! restarting with the peripherals plugged in...has me no longer ripping out my hair in handfuls.

    Thanks!!

    ----------

    each time I come here... I have to figure out how to flag the thread as having been resolved. this time I can't ... seem to arrive at figuring out how to do it.

    if someone could remind me I'll email myself the information so I won't have to ask again. sorry I'm such a fool today...
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    Click Edit on your first post, then Go Advanced. There you'll see where to add a prefix.
     

Share This Page