Is there a way to force iPhone 4 to search for 3G connectivity if it's on GPRS/EDGE?

Discussion in 'iPhone' started by FXT 1, Aug 25, 2010.

  1. FXT 1 macrumors 6502

    Jul 14, 2009
    I was just wondering whether there was a way to force iphone 4 to search for 3G connectivity from GPRS/EDGE as I live in an area with moderately weak 3G. I was able to do this on my iPhone 3G simply by toggling the 3G switch in settings but Apple must have seen this as a bug and corrected it, toggling 3G on my iPhone 4 no longer forces it to search for 3G.

    Is there any way to do this on iPhone 4? Is it something to do with iOS4 ?
  2. Intell macrumors P6


    Jan 24, 2010
    It automatically searches every few minutes. If you still want to force it, try toggling Airplane Mode.
  3. 184550 Guest

    May 8, 2008
    Couldn't you just turn 3G on/off in settings to force it to look for the 3G signal? Like on the 3GS?
  4. DiamondGCoupe macrumors 6502

    Nov 12, 2007
    No it's just going to pick up the strongest signal. Only thing you can do for now is what you have been doing.. I get this occasionally in certain areas in LA.
  5. bobdigi macrumors regular

    Jun 23, 2010
    Baton Rouge, LA
  6. Moe UK macrumors regular

    Apr 28, 2009
    I used to have this issue when I was on o2 with my 3G at my work place. A quick reboot of the phoen would force it to look for the network again and most times it would then latch on to a 3G signal.
  7. elwood2 macrumors member

    Mar 20, 2009
    If your iPhone4 is jailbroken, SSH to /var/preferences/csidata. Save a copy of the file to your computer.

    Open the file in notepad or some other text editor and look for “GsmRegistrationModel::fRatSelection=0×1″ and change "0x1 to 0x2", save the file and upload it back to your phone and replace it. Reboot your phone and you will have 3G only and if there's no 3G signal it will search for signal for a while then go to "NO SERVICE". It will only connect to 3G and never Edge until you change it back.

    This works for the 3GS on 3.x. I have not looked at my iP4 yet to see if the file location is still the same.

    Here's the other settings:

    0×0(EDGE ONLY)
    0×2(3G ONLY)

    Let me know if it works.
  8. macinmac macrumors member


    Jul 30, 2011
    I would also try to enable 3G and then select network manually instead of automatic.

Share This Page