Is there a way to get SMS to NOT pop up on home screen??

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Cusipz, Jul 22, 2008.

  1. Cusipz macrumors newbie

    Joined:
    Jul 13, 2008
    #1
    As the title says, I'd much rather see a "1" or whatever number on the SMS icon, like it works for Email. I don't like it popping on the home screen forcing you to take action before doing anything else..

    Does anyone know if this can be changed?

    Thanks!
     
  2. aljlin macrumors regular

    Joined:
    Sep 7, 2006
    Location:
    CA
    #2
    Under settings>General>passcode lock, you can turn off SMS preview.

    I just checked it and it doesn't show the sms.. it still shows the # and that there is a text message but it doesn't show the txt message if you are worrying about security and such.
     
  3. Cusipz thread starter macrumors newbie

    Joined:
    Jul 13, 2008
    #3
    Thanks so much! Never looked in that section because I hadn't set a passcode. Was looking for SMS everywhere else in the settings!
     
  4. bassy macrumors newbie

    Joined:
    Jul 13, 2008
    #4
    thanks alot for that buddy, same as never thought to look there...
    AAA+++
     
  5. phannon666 macrumors regular

    Joined:
    Feb 1, 2008
    Location:
    Bucks, UK
    #5
    I had wondered about this as well! But after looking, when I go into password lock... there's nothing but a keypad for me to set it, which I don't really want to do. Am I completely blind, or do you have to set a passcode first?:confused:

    ***EDIT***

    nvm, I decided to put in a lock code and it popped up, then I turned of the code, cheers anyway :)
     
  6. themanthegiant macrumors newbie

    Joined:
    Jul 22, 2008
    #6
    i turned sms preview off but when i receive a text, i still see the message. do i need to reset the phone?
     
  7. phannon666 macrumors regular

    Joined:
    Feb 1, 2008
    Location:
    Bucks, UK
    #7
    I just realised this as well, seems like you HAVE to have the passcode lock enabled for the Disable SMS preview option to work at all. Pretty irritating... but a minor niggle on an otherwise amazing phone.
     

Share This Page