Is there a way to NOT have Airport turn on by itself with every restart?

Discussion in 'macOS' started by doug in albq, Apr 4, 2008.

  1. doug in albq Suspended

    doug in albq

    Joined:
    Oct 12, 2007
    #1
    Is there a way to NOT have Airport turn on by itself with every restart?

    I know, I am in a small group when I say I do not ever use or need (at this time) my Alum. iMac's Airport card to turn on.

    But I cannot figure a way to not have it automatically turn itself on with every restart.
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    try ticking a few of those 3 boxes in Airport's advanced preferences in Network Preferences.
     
  3. doug in albq thread starter Suspended

    doug in albq

    Joined:
    Oct 12, 2007
    #3

    could you be more specific?
     
  4. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #4
    sure! open System Preferences which is the cog icon in the dock or you can open in from the  menu. open "Network", click "Aiport" in the sidebar on the left and click the "Advanced" button. then the following window blind will appear. try unticking the box next to the top red arrow and ticking the box next to the bottom red arrow.

    Screencapture 1.jpg

    but im not sure if this will work though (cant be bothered rebooting hehe :)). have you tried simply turning off Airport via its Menu Bar icon before restarting?
     
  5. doug in albq thread starter Suspended

    doug in albq

    Joined:
    Oct 12, 2007
    #5

    I have my advanced airport options set up the way you said I should change it, they have been that way.

    Yes, I turn off Airport in the Menu bar every time I start up (hence, before restarting the next time). But, Airport still always automatically starts itself up with every restart.
     
  6. killmoms macrumors 68040

    killmoms

    Joined:
    Jun 23, 2003
    Location:
    Washington, DC
    #6
    Why exactly do you need it off? I mean, if you're not using it to connect to anything it won't affect any of your other network connections, so...

    I didn't know it turned on after a reboot though. Chalk that up to me both using Airport and hardly ever rebooting I guess. :eek:
     
  7. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #7
    in Windows theres a setting to not make the wireless connect automatically after logging in. the wireless is still on its just it doesnt connect to your network automatically.

    this is the same as unticking "Remember any network this computer has joined" in the window above.

    i guess people like this option. i know i like to use it in Boot Camp when gaming to minimise malware.

    when you startup does the Airport icon in the Menu Bar have bars or no bars? if no bars then Airport has not remembered your network which is what u want. there is no point in turning Aiport off unless you have a MacBook in which you would gain battery life.

    also why are you rebooting all the time? as killmoms said above Mac users hardly ever reboot because of the stability of OS X. just sleep using the "command-option-eject" keyboard shortcut and it resumes instantly!
     
  8. doug in albq thread starter Suspended

    doug in albq

    Joined:
    Oct 12, 2007
  9. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #9
    ok i think i found the answer for you but it was nothing more than just messing around with the settings in Network preferences which you could have done. i had to restart to try this for you :(

    have the same settings ticked and unticked as above.

    untick "Ask to join new networks" in the main Network preferences window. this isnt required but will prevent Airport from prompting you to join other wireless networks when you log in if there are a few in you neighbourhood. i dont pick up any so i just leave this ticked.

    Screencapture 1.jpg

    remove your network name from "Preferred Networks:" in the Advanced window blind by clicking the "-" button and press OK.

    Screencapture 2.jpg

    then make sure you press Apply.

    this will make Airport not connect to your wireless network automatically on login and the Airport icon will have no bars. to connect to your network just select it from the Airport Menu. as i said above just leave your Airport on theres no reason for turning it off on an iMac.
     
  10. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #10
    If you really don't want to use Airport, why not just remove it form your network configuration? You can always add it back in later.

    Open the Network System preferences, then click on "Airport" in the left hand pane. If the Padlock at the bottom left is locked, click on it, and enter your password when prompted.

    When the lock is unlocked, click the "-" to delete the Airport from your configuration. Click "Apply", and you should see the Airport turn off in your menubar. I think it will go away also.

    This should take care of it...
     
  11. doug in albq thread starter Suspended

    doug in albq

    Joined:
    Oct 12, 2007
    #11

    Thanks so much, that took care of my issue. I should have thought of that myself.

    (FYI, I do not use Airport or a home network ever. I have one computer hooked up to a dls modem with an ethernet cable.)
     
  12. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #12
    I'm confused by the question. When I choose "Turn Airport Off" using the Airport menu extra (that icon in the menubar) it stays off until I turn it back on. This is true for reboots, power cycles, the works.

    A.
     

Share This Page