is there a way to update to 10.14.1 with non-APFS boot volume?

Discussion in 'Mac Pro' started by calmasacow, Nov 2, 2018.

  1. calmasacow macrumors member

    calmasacow

    Joined:
    Jun 13, 2012
    Location:
    Houston, TX
    #1
    I have Mojave running on non-APFS volume. due to this it is not letting me install 10.14.1. is there anyway I can get around this?
     
  2. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Clone it to a APFS volume -> update the clone to 10.14.1 -> clone it back to HFS+ volume.
     
  3. calmasacow thread starter macrumors member

    calmasacow

    Joined:
    Jun 13, 2012
    Location:
    Houston, TX
    #3
    yeah I just finished doing just that. what a nightmare. took about 8 hours all in all. Why such a heavy handed approach to forcing the use of APFS. especially when it is in such a state that is is still incompatible with other things. they need to finish fixing APFS before they force it on everyone.
     
  4. jscipione macrumors regular

    jscipione

    Joined:
    Mar 27, 2017
    #4
    Running HFS+ on Mojave is like running UFS on Panther, technically possible but not recommended and asking for trouble. I am interested in running an APFS RAID 0 in Mojave as I'm currently stuck with HFS+ on High Sierra.
     
  5. h9826790, Nov 3, 2018
    Last edited: Nov 3, 2018

    h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #5
    You experience issue with APFS in Mojave?

    I don't like APFS at all. I only use HFS+ in High Sierra after hit some annoying bugs with APFS during early High Sierra, but I must admit that I haven't encounter any issue due to APFS in Mojave yet. Even the Windows Bootcamp apps now can see the APFS boot drive. So, really zero issue for me up to this moment.
     
  6. orph macrumors 68000

    orph

    Joined:
    Dec 12, 2005
    Location:
    UK
    #6
    just use APFS, it looks like apple wants that and you dont know what kind of bugs/problems you may hit if you keep risking it (osx10.14 is so new at the mo, there will be bugs maybe big ones until osx10.14.3 at least)
    if you do stick to HFS+ try to backup your drive/data before any updates (im super scared of data loss, iv spent to much time on work to lose it).
    just to re install all the apps i need for work may take a day or two :confused:

    i dont see any need to use osx10.14 yet and i dont see any need to use HFS+ with osx10.14 but when i do swap ill just do what apple wants, not worth the time each update to re clone the drive.

    keep life simple and fun :D
     
  7. Synchro3 macrumors 68000

    Synchro3

    Joined:
    Jan 12, 2014
    #7
    Is there a Boot Camp update available? Apart from the Mac Pro I have a Mac Mini 2012, but in Windows I cannot select the APFS formatted volume as startup disk.
     
  8. startergo macrumors 65816

    startergo

    Joined:
    Sep 20, 2018
    #8
    Follow this link
     
  9. Macschrauber macrumors 6502

    Macschrauber

    Joined:
    Dec 27, 2015
    Location:
    Germany
    #9
    You can go the unsupported road like I do on Mac Pro 3.1 cause I dont want to patch the firmware for apfs boot.

    Install via DosDudes patcher, for updates run the full installer. It keeps data and settings. Just did 14.1 that way.
     
  10. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #10
    What incompatibilities have you found?
     
  11. Synchro3 macrumors 68000

    Synchro3

    Joined:
    Jan 12, 2014
    #11
    Link does not work.
     
  12. crjackson2134 macrumors 601

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #12
    Check your pm’s
     
  13. startergo macrumors 65816

    startergo

    Joined:
    Sep 20, 2018
  14. orph macrumors 68000

    orph

    Joined:
    Dec 12, 2005
    Location:
    UK
    #14
    simple solution is to stay in osx10.13 :D
    if you know it will bring problems and you need feature 'X' dont upgrade
    wait and see, maybe it will be fixed or maybe there will be a work around.
    with the mac min if you has a DVD drive swap it with a SATA drive and install windows on that id gess to be the work around, two drives are fine on osx10.14 you only have problems trying to use the same drive.

    think i was stuck on osx10.8 for years as i had adobe CS3 (full set up apps) and it broke after that OS on mac and did not want to start using windows just for CS3.

    VM is the second option for 10.14 but wont work well for games
    wine is a 3rd option works well with most pre DX10 games
     

Share This Page

13 November 2, 2018