• Did you order new AirTags? We've opened a dedicated AirTags forum.

Seandroid

macrumors regular
Original poster
Mar 21, 2012
156
90
Canada
When my old iMac was running RCT 3 Soaked for Mac the reflective water worked fine, but I recall after an OS update the reflective water stopped working on that computer.

It also stopped working on my then Macbook.


So I purchased RCT 3 Platinum on disk and attempted to see if maybe they had fixed the issue in that version of the game when it was released, and they had not.

I also purchased it from the Mac App store and ran into the same issue.

Now I have a late 2011 iMac and a 15" Macbook Pro w/Retina Display... same issue.

I really, really want this bug to be fixed, because the reflective water makes the game so gorgeous. Any help? My water looks like this:

tr1vUti.jpg
 

antonis

macrumors 68020
Jun 10, 2011
2,085
1,009
A quick google search brought this:

This is just a basic tutorial just to show how to get the real reflective water and bloom!

1. Click on the RCT3 icon and hold command
2. Then this screen will pop-up! (I guess it means a game preferences screen)
3. To get reflective water and bloom click Enable enhanced rendering.
 
Comment

Aspyr-Blair

macrumors 6502
Aug 20, 2012
319
34
Austin Tx
When my old iMac was running RCT 3 Soaked for Mac the reflective water worked fine, but I recall after an OS update the reflective water stopped working on that computer.

It also stopped working on my then Macbook.


So I purchased RCT 3 Platinum on disk and attempted to see if maybe they had fixed the issue in that version of the game when it was released, and they had not.

I also purchased it from the Mac App store and ran into the same issue.

Now I have a late 2011 iMac and a 15" Macbook Pro w/Retina Display... same issue.

I really, really want this bug to be fixed, because the reflective water makes the game so gorgeous. Any help? My water looks like this:

Sorry for the delay here!

Your water should definitely not look like that. Does your machine have the dual graphics options? If so, try switching off "automatic graphics switching" in your Energy Saver preferences.
 
Comment

Seandroid

macrumors regular
Original poster
Mar 21, 2012
156
90
Canada
A quick google search brought this:

This is just a basic tutorial just to show how to get the real reflective water and bloom!

1. Click on the RCT3 icon and hold command
2. Then this screen will pop-up! (I guess it means a game preferences screen)
3. To get reflective water and bloom click Enable enhanced rendering.

Yeah - it's enabled in that photo, believe it or not. Haha.

Sorry for the delay here!

Your water should definitely not look like that. Does your machine have the dual graphics options? If so, try switching off "automatic graphics switching" in your Energy Saver preferences.

I have actually. =\ And it happens on my iMac which doesn't have automatic graphics switching.
 
Comment

Aspyr-Blair

macrumors 6502
Aug 20, 2012
319
34
Austin Tx
Yeah - it's enabled in that photo, believe it or not. Haha.



I have actually. =\ And it happens on my iMac which doesn't have automatic graphics switching.

No fun. What OS? I just tested on my desk machine (2011 MBP) in 10.9 with no issues. Ping our support team at support.aspyr.com It could be something totally weird.
 
Comment

n8mac

macrumors 6502
Jun 25, 2006
417
45
Ohio
No fun. What OS? I just tested on my desk machine (2011 MBP) in 10.9 with no issues. Ping our support team at support.aspyr.com It could be something totally weird.

I get the same thing...


Without reflective water



With reflective water. This is on the iMac in my sig running 10.9.1 downloaded from Steam.
 
Comment

Seandroid

macrumors regular
Original poster
Mar 21, 2012
156
90
Canada
No fun. What OS? I just tested on my desk machine (2011 MBP) in 10.9 with no issues. Ping our support team at support.aspyr.com It could be something totally weird.

I did try this actually. I contacted your support team, sent all of my diagnostics info and we had a conversation but it never came to anything and they said it had to be something to do with my software. All of my Macs are on 10.9.1 and all of them display this. =\
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.