Issue w/ 4K monitor & 2008 MP 3,1 OS 10.13.6

Discussion in 'Mac Pro' started by Kiru, Dec 11, 2018.

  1. Kiru macrumors newbie

    Kiru

    Joined:
    Dec 11, 2018
    #1
    I recently bought a Benq 4K 32" monitor and am running into an odd and annoying issue... the 4K monitor is not detected by the OS at start-up, resulting in a black screen w/ "signal not detected".

    The GPU that I'm using is a flashed Nvidia GT 630 2GB (bought at macvidcards), which supports 4K @60hz.

    I'm running High Sierra on a Mac Pro 3,1... so yes, I'm technically into "unsupported" territory. And due to the EFI, my GPU won't show the grey screen/Apple logo at startup when using 4K resolutions, which doesn't bother me.

    In my testing, if I start the Mac up using my older 2560x1400 monitor, get to the log-in screen, THEN move the Mini DisplayPort cable over to the 4K monitor, the signal shows up fine, and I have 4K @60hz.

    But rebooting with the 4K monitor still hooked up results in the "Signal not detected" message.

    Starting up with both monitors attached vid DP (the new 4K & my original 2560x1400) works; although the 4K stayed black until after boot, it was readily recognized by the system nonetheless, and acted as a secondary screen.

    So... the GPU can handle both screens at the same time, but for some reason the Mac refuses to recognize the 4K on its own...?

    I even tried resetting PRAM, but with the 4K connected, the Mac refused to complete the process (no chime... at all... until I released the key combo). Yet the PRAM reset worked fine with the older monitor attached.

    It just makes NO sense to me, and while I'd love to keep the 4K, screw it if OSX can't make it run correctly.

    Any ideas before I start the return process?
     
  2. Kiru thread starter macrumors newbie

    Kiru

    Joined:
    Dec 11, 2018
    #2
    So lots of views but no ideas, eh? Oh, well, time to start the return process.

    Disappointing that the Mac OS seems to be getting flakier & flakier with each release ("core rot", call it what you will)... or that the unicorn that's the next Mac Pro is probably never going to materialize, or will be so locked down that it'll go against my idea of what an upgradeable workstation would be.

    I'm glad I'll be able to wring a few more years out of my bought-in-2008 3,1 by using High Sierra, but at this rate, my Win 10 box is looking like it'll be the next home for my design biz software.
     
  3. CC88 macrumors regular

    Joined:
    Sep 29, 2010
    #3
    You're not alone.
     
  4. Ludacrisvp macrumors 6502

    Joined:
    May 14, 2008
    #4
    Curious if you were using Nvidia Web drivers or using native OS drivers.
     
  5. Kiru thread starter macrumors newbie

    Kiru

    Joined:
    Dec 11, 2018
    #5
    Hey... the day I first tested the monitor for dead pixels, I'd installed the recent security update, so the Mac had reverted to native OS drivers.

    The next day, updated drivers came out (387.10.10.10.40.113), I installed them, but got the same results w. the monitor.

    It just seems like the Mac can't see the 4K monitor during the boot process at all (hence the PRAM reset not working as it should... where I'll never hear the boot chime as long as I keep the PRAM key combo pressed), and will only work if a lower Rez monitor is connected.

    This is the first time in all my years ('85 to now) building & using computers/monitors that I've had a problem like this. Something so basic shouldn't be such a time drain, but hey, it's the new Apple, I guess. iPads or the highway.

    Too damn fiddly for a machine that I use for gainful employment.
     

Share This Page

4 December 11, 2018