Issue with finder sidebar

match14

macrumors member
Original poster
May 1, 2014
30
20
I have a MacBook Pro 16" running macOS Catalina. On the finder sidebar Macintosh HD keeps disappearing. If I go to the Fider preferences the option for Hard Disks is ticked. If I untick and then restock Hard Disk the Macintosh HD does not come back. If I log out and then log back in again then it will reappear for a couple of days and then disappear again. I had tried deleting the com.apple.finder.plist file but it keeps happening I have even booted into safe mode and then rebooted but it still happens. Has anyone ever seen similar?

Any help appreciated
 
Last edited:

chscag

macrumors 68040
Feb 17, 2008
3,381
1,077
Fort Worth, Texas
Use your mouse or trackpad cursor and point it to the word "Locations" (should be at the bottom) in the Finder sidebar. You'll then see a popup appear that states: "hide" or "show". Make sure you select "show". If you already have it set correctly and the problem still happens, something else is going on.
 

match14

macrumors member
Original poster
May 1, 2014
30
20
Use your mouse or trackpad cursor and point it to the word "Locations" (should be at the bottom) in the Finder sidebar. You'll then see a popup appear that states: "hide" or "show". Make sure you select "show". If you already have it set correctly and the problem still happens, something else is going on.
It is already set to show, I can see my iPhone, iPad, Network and NAS under locations.
 

match14

macrumors member
Original poster
May 1, 2014
30
20
Not at my Mac...
Did you look for a Sidebar plist file? Can't remember if I've ever seen one.
I have looked for a sidebar.plist file but could not find one, I have read some information to suggest that Catalina does not have a sidebar.plist file
 

match14

macrumors member
Original poster
May 1, 2014
30
20
This has happened again and I think it is maybe related to Time Machine.
 

hawkeye_a

macrumors 65816
Jun 27, 2016
1,422
3,709
Another issue with the sidebar and mounted disks:
If I have two disks with the same name mounted, only one of them shows up in the sidebar. (In Mojave, both would show up).