Issues putting a hard drive in the optical bay of my early 2011 MacBook Pro

Discussion in 'MacBook Pro' started by TheForrestFire, Jun 27, 2014.

  1. TheForrestFire, Jun 27, 2014
    Last edited: Jun 27, 2014

    TheForrestFire macrumors newbie

    Joined:
    Jun 27, 2014
    #1
    I'm asking for help for my brother! I recently switched over to a dual hard-drive setup, and it worked perfectly. However, my brother is having issues.

    First off, here is the hard drive we are trying to put in the optibay, using this caddy. Both worked perfectly when doing this to my computer. If we can get this HDD to work, we'd like to put this SSD in the main hard drive bay.

    He has an early 2011 15" MacBook Pro. We read up online, and people said that the optical bay for his model only has SATA II, while the main bay has SATA III, which means he should put his HDD in the optical bay, and the SSD in the main bay. He wants to put the HDD in the optical drive area, and then transfer everything over to the new HDD, before putting the SSD into the main bay.

    The issue is that when we put the HDD in the optical bay, the computer can basically not recognize or use it. If plug the HDD in via a usb cord, he can initialize it and erase it to Mac OSX Extended (Journaled) perfectly fine. It only takes a few seconds, and as far as I can tell, it works. However, when he actually puts the hard drive in the optical bay, it either doesn't show up in disk utility, or it shows up, but can't be accessed or changed.

    We left it in, and it showed up after 30 minutes or so. When he tried to initialize it, however, the computer said it'd take 5 hours to do. The progress bar ended up getting half way done, and then stopping, so that didn't even work.

    We thought that maybe it could be a firmware issue due to this post that we found, but we looked and definitely have the newest firmware version (2.7, I believe). Also, I don't think that thread applies to us, since we aren't even beginning to deal with the SSD yet, just the HDD.

    We also tried just initializing it before putting it into the computer, but the computer doesn't seem to recognize it correctly. The name is changed from "New HDD" to "disk1s1", and we can't actually access it. That's when we tried initializing it again, just for the progress bar to get stuck.

    Looking online, this setup should work. Tons of people have done it, even using the hard drive we are using. We aren't even trying to put a SSD in yet, which is where most people have problems with the 2011 model. This is just a regular hard drive! I don't understand what could be wrong, and could use some help!

    Thank you!
     
  2. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #2
    What kind of optical bay caddy are you using for the hard drive? If it's one of those $8 jobs from Amazon, that's probably why it's not working. They cost more, but I would suggest purchasing the MCE Optibay or OWC Data Doubler. The latter is available from Amazon for $35, so you'd get free shipping, and it comes packaged in a nice box with a toolkit, screws, and printed instruction manual.
     
  3. TheForrestFire thread starter macrumors newbie

    Joined:
    Jun 27, 2014
    #3
    We thought that might be the problem, but when we plugged the HDD + Caddy into the computer via USB using this, it worked perfectly. We were able to partition the HDD, and everything. I think that implies the Caddy is working fine, right?
     
  4. Dekard, Jun 27, 2014
    Last edited: Jun 27, 2014

    Dekard macrumors 6502

    Dekard

    Joined:
    Sep 7, 2011
    Location:
    Dallas, Texas
    #4
    I believe you might just need to swap the drives. The original apple HDD needs to be in the optibay, and the second drive needs to be in the place where the original drive was, apparently when moving the optibay it doesn't know where the apple drive is any longer. (at least this was the known issues back when I did it on my 2011 MBP)
     
  5. TheForrestFire thread starter macrumors newbie

    Joined:
    Jun 27, 2014
    #5
    We read that for the early 2011 MBP, the SSD has to be in the main hard drive bay, while the HDD has to be in the optibay, because the optibay only has SATA II, while the main bay has SATA III.

    Normally, I think you're supposed to put the SSD in the optibay. You're only supposed to do it this way for the 2011 models.

    This link is where we got some of that information. I think we're going to try putting the SSD in the optibay tonight to see what happens though!
     
  6. jg321 macrumors 6502

    Joined:
    Aug 29, 2012
    Location:
    UK
    #6
    This probably doesn't help, but I thought I'd share my experience. I had a Feb 2011 13" MBP, Corsair SSD in the main drive bay, original HDD in a cheapo eBay optibay jobby. Worked a treat.
     
  7. Barney63 macrumors 6502a

    Barney63

    Joined:
    Jan 9, 2014
    Location:
    Bolton, UK.
    #7
    Is it possible that the internal drive cable has crapped out?


    Barney
     
  8. bennynova macrumors member

    Joined:
    Jun 6, 2014
    #8
    ughh.

    i am having the exact same type of problem

    i have an early 2011 mbp 13"

    i purchased an evo 840 sad and have had trouble getting the mac to recognize it.

    SSD is visible using an external USB setup.
    while i was doing this, my original HDD is viewable using the main SATA internal hub

    after formatting and applying OS mavericks to the SSD, i made it the start up disk and switched it to the internal main SATA hub.

    the mac couldn't find it at first, but after taking it apart again and re-seating it, the SDD showed up and actually booted my system in about 10 seconds.

    however, after using it for 2 minutes, i got the rainbow wheel of death and the mac no longer could find the SSD.

    i have replicated that 2 times now.... could it be an issue w/ the SSD jostling around a little bit in the hub?

    i was going to get an optical bay SSD fixture....... but if it's only SATA II... then will it even recognize it?
     

Share This Page