iStumbler shows router, but airport won't connect

Discussion in 'iMac' started by donnie3000, Feb 19, 2009.

  1. donnie3000 macrumors member

    Joined:
    Apr 20, 2004
    #1
    Sorry if this is dealt with elsewhere, but I couldn't find anything with the same specific details:

    My airport connection to the wireless router has, over the last few days, been becoming increasingly flaky and intermittent followed last night by a total refusal to connect.

    It had been working fine for at least a year up until recently.

    The funny thing is that iStumbler finds my router(as well as some neighbours'), and reports a signal strength similar to what I have always had.

    Problems started as follows:
    iMac would show full bars, then no bars and then full again, followed by a slow drop to nothing. Turning airport off and back on again, would repeat this process. Occasionally, the iMac would also require the WPA2 password.

    And progressed to:
    Over a few days things got worse to the point that I had no usable connection and the airport would not always pick up any networks and would request the WPA2 password repeatedly always followed by a 'Connection timeout'.

    I would say that the airport extreme card is broken, except iStumbler is reporting 'normal' service. Also, my iPhone reports full signal strength sitting next to the iMac!

    Can anyone shed some light on this?

    Typically, Applecare expired all of 2 weeks ago!!!
     
  2. tersono macrumors 68000

    tersono

    Joined:
    Jan 18, 2005
    Location:
    UK
    #2
    Don't panic - it's doubtful that there's a hardware fault.

    The likelihood is that one of your neighbours' routers is on the same channel as yours and is clashing. Try switching channels - if that fails, try moving the router to a different location in your house.
     

Share This Page