It has taken 6 hours to transfer 18gb of files, why?

Discussion in 'macOS' started by adamsn00, Nov 3, 2018.

  1. adamsn00, Nov 3, 2018
    Last edited: Nov 3, 2018

    adamsn00 macrumors newbie

    Joined:
    Oct 28, 2018
    #1
    [EDIT: MacOS is reading/writing all USB drives incredibly slow. I've tried 2 USB HDD, and 3 USB Flash Drives. All of them are incredibly slow even for just viewing files. read/write speeds fluctuate drastically between upwards of 10mb/s down to 5kb/s. But copying 500mb of files takes 5 minutes. That includes transferring files from my Mac's SSD to a Flash USB Drive. Mojave is reading/writing to USB incredibly slow]

    [EDIT: ALL OF MY FILE TRANSFERS AND ATTEMPTS TO CREATE .ZIP ARCHIVES SLOW TO A CRAWL (like, under 100kb/s) AFTER 65%. Regardless of drive, because I've now tested with 4 different drives.)

    I have a MacBook Pro late 2013/early 2014 model, running Mojave. It runs great with no issues. I'm transferring backed up photos from my external Seagate 2tb USB drive (about 125gb all together) to a 128gb PNY USB flash drive. (both USB 3 drives)

    MacOS says it will take 5-6 days to transfer 128GB. So far it has taken 6 hours to transfer 18gb.

    Needless to say I'm frustrated. Any ideas as to why it's taking so long?

    My read speaks are 1.4/sec or less
    My write speeds are even slower.

    How is it possible that my read/write speeds are 1.4mb/sec????

    PS. the usb flash drive is formatted as MacOS extended journaled. The seagate 2tb drive is factory formatted. Probably FAT, not sure.

    Thank you,
    Adam
     
  2. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Really really stupid question coming up. Please don’t feel patronised.

    Have you tried restarting your computer with the “reopen windows” option unchecked and attempting the transfer again?
     
  3. adamsn00, Nov 3, 2018
    Last edited: Nov 3, 2018

    adamsn00 thread starter macrumors newbie

    Joined:
    Oct 28, 2018
    #3
    No, I didn't try that. I wouldn't think that would have much to do with data transfer speeds.


    I stopped the transfer I was doing and am now trying to create a .zip file form my 125gb of pictures. That didn't work using MacOS default compressor functionality. So, now I'm using an app called "archiver." It started out fast, but not it's hanging at about 65%. (it's been stuck there for over 30 minutes) This is a nightmare.
    --- Post Merged, Nov 3, 2018 ---
    I just restarted without the "reopen windows" option. I'm now trying to create a .zip file from my 125gb pictures folder, but it's not working. It gets about 65% done and then just stops, and starts "not responding." So, I imagine transferring files would be the same way.
    --- Post Merged, Nov 3, 2018 ---
    I attempted to transfer files again and I'm getting transfer rates in the kb/s. Luckily I have another drive with the files on it and I will try that. It may be that this seagate drive is going to die on me.
    --- Post Merged, Nov 3, 2018 ---
    I'm now transferring files from an older Seagate USB (1TB) drive. And it's going much faster.

    [EDIT] It WAS going faster. Now these transfers appear to be sowing down as well. Not nearly as slow as the seagate drive, but now the transfer is stuck at about 65%, just like the previous Seagate drive. WHY would this be happening?

    PS. I've tried 3 different PNY 128gb flash drives, is I know it's not that.
     
  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    I think that you'll find that most "USB3" flash drives have decent read speeds, but the write speeds leave "much to be desired". I also have a PNY flash drive (I believe it's also "USB3"), and it's downright pokey at writing files.

    I would expect almost -any- large-capacity transfer to a USB3 flashdrive to be "on the slow side".

    Insofar as transfers to "hard drives" (not "flash drives") is concerned, are you using USB3 cables? All "USB cables" are NOT the same.

    I believe USB3-compatible cables have a "blue" spacer visible when you look at the plug.

    What I'd advise.
    GIVE UP trying to put that much stuff onto a USB flash drive at once.

    Instead, transfer the data to hard drives (either platter-based HDDs or SSDs).

    Don't have too many (any?) other peripherals connected during the file transfers.

    Don't try to "copy it all" at once.
    Instead, copy, say, 20gb at a time. Keep notes.

    Question:
    Is the drive you're transferring to "empty" or does it already have files on it?
    You might consider downloading CarbonCopyCloner (FREE to download and use for 30 days) to "clone" from your source to your target.
    CCC even has something called a "safety net" that will leave files that are already on the target untouched.
     
  5. !!! macrumors 6502

    Joined:
    Aug 5, 2013
    #5
    When you say it keeps hanging at 65% it makes me think that there's some file that's corrupt or an issue with the HD itself. Where are you copying these files from? Try running Disk Utility's first aid on both drives. How full are the drives you are transferring to? Do you experience the same problem with copying another large set of files (maybe try copying the Applications folder)? How many individual files are you transferring? You mention that they are images, if there are thousands of really small images then it could take extremely long, considering that macOS has to initiate a new IO transfer for every file as well as modify the filesystem to add each one to the journal and file table.
     
  6. adamsn00 thread starter macrumors newbie

    Joined:
    Oct 28, 2018
    #6
    Thanks for the reply. I'v been doing what you suggested. Transferring smaller chunks at a time. It took 11 hours to copy about 38gb. And 6 hours to transfer the first chunk - which was something like 20gb. Now I'm transferring 52, and I'm not counting the hours this time. I don't really care anymore, as long as I get these photos backed up on more than one disk. When I started I had two working HDDs, the new seagate started beeping (the reason I started doing this additional backup), but it seems to be working fine now, but my older seagate drive won't even mount anymore. It just makes a clicking sound like the needles is dragging across the platter, or something. It's a shame. I lost a lot of recent jobs I had completely for clients. Which I don't really NEED except for portfolio use. But it still sucks. I wasn't able to get all of those particular files to my new seagate before the old Seagate failed. The new Seagate seems to be working fine now. I think the reason it was beeping the day I got it was because of a power issues as it was plugged in via hub. It worked fine at first, and transferred 600gb of files. Then started beeping. I can only assume it was a power issue, since it seems to be working fine now. Everything is just REALLY SLOW!!

    As far as USB3 goes, my new seagate drive claims to be USB3, but I don't know. I an't check the cable right now because it's plugged in and transferring.

    But I can put up with slow as long as I save my photos. But from now on I will focus on online storage - Google Drive, iCloud, etc. My upload speeds are faster than this my disk writing speeds.
     

Share This Page

5 November 3, 2018