IT illiterate MBA owner can't restore from TM; it's you guys or back to Apple Store!

Discussion in 'MacBook Air' started by katyt, Aug 17, 2013.

  1. katyt macrumors newbie

    Joined:
    Aug 14, 2013
    #1
    Had problems with my MBA, Genius Bar replaced Hard Drive, came home and switched on, all good so far.

    I have a Time Machine & I know I have a good backup from Aug 5th.

    I cannot get it to restore though. Firstly I know (now) that I was on a new account that wouldn't access any backup after Nov 2011. I've managed to change back to my proper account and I can see the Aug 13 backups now.

    I think I've tried to restore something a couple of times, certainly the machine has worked overnight doing something! But no photos or documents back yet :(

    And I may have inadvertently filled up my Hard Drive by doing whatever I've done!

    So, I need an Idiots Guide to restoring from my TM, otherwise I'll have to trek back to the Apple Store with MBA & TM in hand and try and get them to sort it.

    TIA, Katy
     
  2. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #2
    Sorry that happened - the good news is that you were smart enough to back your data up so you should be ok!

    are you trying to just restore the entire system or pick and choose specific files?

    if you haven't already take a look at this page:
    http://support.apple.com/kb/HT1427

    specifically scroll down to Restoring data from Time Machine backups and read that. If that doesn't cover everything you need let us know and we'll help.

    Alternatively the guys at the genius bar could help too if you brought it all back to them.

    Basically, if you want to just pick and choose files you can go to "enter time machine" fine the file and restore or drag it where you want. if you are looking to restore the entire system you will need to do that in recovery mode or use migration assistant as if you were loading from one mac to another.
     
  3. katyt thread starter macrumors newbie

    Joined:
    Aug 14, 2013
    #3
    Thanks for replying - I want to restore the whole thing, basically I want it back to where I was pre-new hard drive. (well without the near-constant colour wheel I was getting and running at snails pace!)

    I will have a look at that link, I have fiddled about with Migration Assistant & using my Snow Leopard disk but not sure I've been doing anything in the right order!
     
  4. katyt thread starter macrumors newbie

    Joined:
    Aug 14, 2013
    #4
    OK, this is where I start with problems - i can't seem to make it restart in recovery mode.
    I've tried turning it off then on again whilst holding down cmd + R and it just restarts as normal as if i'm not doing anything?
     
  5. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #5
    sorry, i didn't subscribe to this thread so i didn't notice you had replied. one thing you can do is click quote rather than post reply and that will give the person you are replying to a notification that someone has quoted them. Not sure if most people on here sub to every thread they post to but i certainly don't.

    that being said this is an active community so if your thread is a day or two old you will definitely get some responses and hopefully help - and help from people smarter than i am:p

    anyway... which MBA do you have, what year and what version of OSX are you running? is it updated?

    to boot into recovery mode what i like to do is shut down. press power and as soon as you hear the chime press command-r and hold it until recovery boots up. from there you should see an option to restore from time machine.

    i am sure you know this but make sure you are pressing the command key, not one of the others.

    [​IMG]

    the green one

    ----------

    also, in case this applies make sure you're doing it on the mac's keyboard, not on a wireless or usb plug in.

    is filevault active?
     
  6. katyt thread starter macrumors newbie

    Joined:
    Aug 14, 2013
    #6

    Trying to quote, not sure if I've done it right...

    Thanks for coming back to me.

    Yes to Mac's keyboard.
    Yes to Cmd button, even tried the other side one just in case but it just restarts ignoring me!

    The laptop is from 2009, I've had the hard drive replaced before (2ish years ago, and I must've managed to restore it back then), and I upgraded to Snow Leopard (so it must've come with something else? can't remember, just know I have the SL disc).

    If I click on 'About This Mac' it says I'm on 10.6.8

    I did check for updates the other day but will do again in a mo.

    I also checked Cmd + + just to check and the Cmd button does work.

    I'm going crazy with this now! Getting to the Apple Store is a real mission with 3 kids, p-t work, etc. Was so hoping Apple would talk to Apple and it would all be sorted!

    ----------

    PS I have no idea what 'filevault' is....:confused:
     
  7. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #7
    hmmm...well - the good news is the quote button worked ;-p

    so it's a 2009 macbook air. do you have an external DVD drive and the disc that came with it? you could try it that way

    ----------

    filevault is Apple's disc encryption. it can block booting to safe mode, not sure about recovery. just trying to figure out why it's not working for you. somebody more knowledgable will chime in soon hopefully.
     
  8. katyt thread starter macrumors newbie

    Joined:
    Aug 14, 2013
    #8

    Haha, yey I can quote :)

    Yes I have an external dvd drive, I have the Snow Leopard disc. I must have the original disc somewhere too - but when I first came home with the new hard drive it kept wanting to update so won't I have to have SL loaded to allow me to access the TM-saved versions which would be SL too?
     
  9. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #9
    if you can use it to get into recovery mode you will have an option to just restore from TM. i am thinking find that disc, plug it in, boot up and hit com-r and see if that does it for you.
     
  10. katyt thread starter macrumors newbie

    Joined:
    Aug 14, 2013
    #11
    Ok on phone now so sorry can't figure out quoting!

    No luck - I found my install disk 1 and plugged it in - now the laptop is stuck in a startup/not quite starting mode and keeps chiming but mostly a grey screen without even the apple logo.

    I'm doomed :)
     
  11. katyt thread starter macrumors newbie

    Joined:
    Aug 14, 2013
    #12
    So, if I have the external hard drive plugged in, nothing good happens, regardless of combo of keys held down for starting up.

    If I unplug it, the laptop starts up normally regardless of what keys I hold down...:confused:
     
  12. magbarn macrumors 68000

    Joined:
    Oct 25, 2008
    #13
    Does the external drive have a confirmed working copy of OSX? Not quite understanding you. OTOH, I have used a few cheap external hard drives that would freeze my macbook on boot, but work fine if I plug them in after OSX has done booting.
     
  13. katyt thread starter macrumors newbie

    Joined:
    Aug 14, 2013
    #14

    It's the external hard drive - by this I'm showing my illiteracy I mean the plug in external thingie that I put a disk in! External disk drive I guess, doh - I got from Apple with the laptop.

    It has my original Mac OSX Install Disk 1 in and it makes lovely whirring-I'm working noises when I hold down C on startup but then it gets 'stuck' in a cycle of chiming/grey screen/goes black/and repeat.

    I was trying to use my Snow Leopard upgrade disk but that wasn't doing anything that I could see. Though I have successfully upgraded I think from whatever my original settings were to Snow Leopard because I could see my backups on the TM.

    However - have just tried to look at TM and it says I need to set it up. Sigh. I am going backwards I think :(
     
  14. DisplacedMic macrumors 65816

    Joined:
    May 1, 2009
    #15
    what happens if you put the disk in while the computer is loaded normally, does the drive work?

    this is a 2009 macbook air? so that was Leopard, right? That's what it came with? And then later you purchased Snow Leopard, and now you are running Mountain Lion?

    We could try using migration assistant....

    Click on your applications folder, then utilities, then migration assistant. that should help you restore from Time Machine.

    When they changed out your hard drive at the Apple Store did they, by any chance, also change out your logic board?

    ----------

    ok yeah - migration assistant should work for this.
    open it up, you're going to need to close everything else, and work your way through the settings. you are going to restore from a time machine drive. it will then ask you to pick your system from a list of systems backed up on your hard drive - you might just have one, but some people use the same drive for multiple machines.

    pick your machine, then it will start calculating sizes and ask you what you want to move over. from there pick what you want and hit continue/restore. that should work.
     
  15. katyt thread starter macrumors newbie

    Joined:
    Aug 14, 2013
    #16
    Hi again, sorry for disappearing, RL got in the way.
    I tried fiddling about with my original disks and got nowhere. So then reinstalled from my Snow Leopard disk. Laptop 'looks' healthy, everything works. I can enter the Time Machine & see my beloved backup, but what do I do next?


    When I look at Migration Assistant, it gives me 2 choices, 1 is the TM (which won't connect for some reason) & 2 I think is just my laptop, but it does go through the calculating step but I haven't tried restoring as i'm sure that can't be right can it? I want to restore from the TM not from the laptop itself?

    So, I can't do Recovery mode in SL (according to Google) - is there an equivalent in SL that will get me back to the beginning page that asks about restoring from the TM vs try later (I chose the try later)?
    What do I actually select to Restore?
     
  16. Mr Rabbit macrumors 6502a

    Mr Rabbit

    Joined:
    May 13, 2013
    Location:
    'merica
    #17
    Yes, there is. You have a couple of options...

    1) This involves booting to your Snow Leopard disc again. Once you're booted to the Snow Leopard disc you should have a "Utilities" menu in the menubar, under which you will find "Restore System From Backup". This option allows you to restore your entire system from your Time Machine backup, rather than individual files/folders like you currently can. See the below picture for reference, it's the bottom option in the menu.
    [​IMG]

    2) This is a bit more involved but only because it involves the command line (Terminal), shouldn't be too bad though. You are basically tricking the Mac into thinking it's booting for the first time, which will trigger the "Welcome to Mac" window that has an option for restoring from a Time Machine backup.
    1. Open Terminal (located in Applications/Utilities
    2. Enter
      Code:
      sudo rm /var/db/.AppleSetupDone
    3. Enter your administrator password when prompted, the same one you would use when installing software or running updates, and click the return key
    4. Once it's finished it will simply show the command prompt unless there is an error message
    5. Assuming it ran without errors you can restart your Mac
    6. When your Mac boots it will boot to the "Welcome to Mac" intro, just like it would when you first bought it
    7. One of the first few steps (step 3 I believe) asks if you would like to transfer information, one of the options should be from a Time Machine backup (possibly under "From Another Disk").

    I don't have a Time Machine backup to test with but I believe you will be able to select your Time Machine drive, select a particular backup (last week for instance) and click restore to restore all of the data from that point in time.

    Hopefully one of those options works for you!
     
  17. katyt thread starter macrumors newbie

    Joined:
    Aug 14, 2013
    #18
     
  18. Mr Rabbit macrumors 6502a

    Mr Rabbit

    Joined:
    May 13, 2013
    Location:
    'merica
    #19
    Awesome, glad it worked out for you!
     

Share This Page