iTunes 10.1 (x64) Failing to Play Purchased Movies/TV Shows

Discussion in 'iPhone' started by gforce216, Nov 12, 2010.

  1. gforce216 macrumors 6502a

    Joined:
    Jun 17, 2009
    #1
    I just finished downloading iTunes 10.1 for Windows 7 and when I tried playing any movies or tv shows I purchased and downloaded through the iTunes store I am only getting a black screen with all of the controls for the movie player. The scrub bar up top reads that the the movies starts at 00:00 but will not move on its own.

    Anyone else have this problem?
     
  2. Juriswilliams macrumors newbie

    Joined:
    Nov 13, 2010
    #2
    Same problem

    I am having that exact same problem. Double click a movie or a TV show and you get a big black screen. It says the movie is in "play" mode but nothing is playing, the scrub bar doesn't move and pausing has no effect. Some of the movies I tried I was already a few minutes into and while it showed I was at "location 8:53" it wouldn't move forward(play). I've no idea what happened. Any help would be appreciated
     
  3. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #3
    Hmmm... I'm able to play a TV show I purchased.
     
  4. johnpaulmetcalf macrumors newbie

    Joined:
    Nov 23, 2010
    #4
    The Answer to your problem

    There are two ways to allow you play your videos one is a work around and the other it the solution that worked for me.

    1. Work around: Play your videos in quick time. This will work till you find the time to do the actual solution.

    2. Solution: Unintall all apple products from your PC and then reinstall iTunes 10.1. This worked for me.
     

Share This Page