iTunes 11.x and iPad 2 1080/720P HD "Home Sharing"


macrumors 603
Original poster
Jan 8, 2009
Owning an iPad 2, a lot of people have experiences a myriad of issues with iTunes 10.7-11 "Home Sharing". Some experience iOS 6.x displaying incorrect movie artwork on their iPad (which seems to be resolved by turning off "Home Sharing" on all Mac's and iDevices, rebooting, then turning "Home Sharing" on), while others are "missing" recently purchased movies from displaying on their iPad's.

I've been experiencing the "hidden movie" phenomenon. Only movies that I have recently purchased do not show in my Video app on my iPad 2. Interestingly, these are 1080P and 720P HD films. I know my device can play the film if I copy it via USB to the device, but why is it not showing on my iPad via "Home Sharing"? Does USB copying "remux" the file to an iPad 2 format that "Home Sharing" cannot? It all seems off.


Found this thread

iPad 2 Home Sharing 1080 Playback

Some state iPad 2 does not support 1080P, or 720P, although copying it to the device works thus it must create a scaled version. However, there are 1080P films that play via WiFi. As someone commented:

As a test, I just changed my 1080p movie metadata from 1080p to 720p using metax for Windows and now my iPad2 sees my 1080p movie via homesharing. Definately a bug with the 1080p metadata stamp to the file.
I modified the tags and it worked. I don't understand what is happening here.

Solved part:

Where's my SD version?

Newer versions of iTunes removed SD downloads when HD versions are purchased. These instructions worked:

Assuming this is in iTunes on a computer:

1 - Go to iTunes Store Home Page (click house icon if needed)

2 - See Quicklinks on the right > Purchased

3 - Select Films or TV Shows

4 - At the very bottom, uncheck Download HD when available.

For HD movies I either see downloaded or a cloud icon to download the SD version.
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.