iTunes 12.6.5 not working in Mojave

GH1852

macrumors newbie
Jul 14, 2015
8
2
Near Chicago
No, it should be working. Just a few days ago I made backups for an iPhone 11 Pro Max and an iPhone XS Max using iTunes 12.6.5.3 on Mojave 10.14.6 (18G2022). Be sure to install the Mobile Device update, see https://forums.macrumors.com/threads/sync-itunes-on-iphone-7-and-ios-13-2-with-imac-and-mojave-10-14-6.2209537/
My iPhone is an iPhone 7 using iOS 12, and my iPod touch is a 5th generation running iOS 9. Do I still need the Mobile Device Update? Sounded like it was needed for newer hardware (maybe).

I should also mention that I did not install iTunes 12.6.5 using the above procedure. I did it by using a script you provided on the iTunes 12.6.5 for Catalina thread, in response to someone who asked you "do you have a script for Mojave". I then had no luck in getting iTunes to launch until I remember the part about iPod framework and copied that into the newer iTunes.

I did all of the above with SIP disabled. As per your recommendations, I also installed iTunesAccess.pkg, , using a link you provide, which I do not know the function of.

I should also mention that I did ONE sync with iTunes 12.6.5 (my first one) when I could see my previous backups and the backup was successful. But immediately after that was completed, I have since lost the ability to either see the old backups or do a successful backup. It almost looks like a permissions issue, as if iTunes 12.6 isn't allowed to see the contents of the folder where the backups are.

I suspect I should perhaps trash the iTunes 12.6.5 I installed and start again from scratch using the method on this page.

Thanks
 

GH1852

macrumors newbie
Jul 14, 2015
8
2
Near Chicago
No, it should be working. Just a few days ago I made backups for an iPhone 11 Pro Max and an iPhone XS Max using iTunes 12.6.5.3 on Mojave 10.14.6 (18G2022). Be sure to install the Mobile Device update, see https://forums.macrumors.com/threads/sync-itunes-on-iphone-7-and-ios-13-2-with-imac-and-mojave-10-14-6.2209537/
I fixed my issue. Started thinking about permissions, checked them on iTunes 12.6 in my apps folder. I was the owner, r, w, x. Group was staff, r, w, x. Everybody was read only. Not normal for an Apple Mac OS app.

Used an app named Batchmod to change owner to System (root), group to wheel, and no changes to Everyone. Everything seems to be fine now.

This probably doesn't happen if you do a package install as per your procedure in this thread.
 
  • Like
Reactions: katbel and bogdanw